Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
FunkyFr3sh

Tiberian Sun patches - Fix for the windows 8 / 10 menu problems and more

Recommended Posts

I hope this helps somehow FunkyFr3sh!

 

Somehow I have a strange feeling (like maybe a bug I recall from 15 years ago) that the menu issue has got to do with the No-CD patch. Maybe I am totally off-point on this and just imagined it.

 

If I can help then let me know!

Oh, didn't see your message! The menu bug is related to ts-ddraw, it was never finished but still good to use in online games since we bypass the menus there

 

I installed this and everything works perfect.

 

One thing, when i windows down or press windows key i can't get the game to pop back up.

There's a black bar top left and i can hear the sound but i can't get the game to show.

 

And how do i change my name?

 

Thank you for this, i love going back and playing this old game that i have a lot of memories with... :D

 

Alt+Tab / windows key is broken on windows 8 / 10, there is no proper solution yet that works for everyone so you'll have to live with that :D

 

Do you mean the name in online games? You can choose it at the login screen

Share this post


Link to post
Share on other sites

Just used the current TS release 10 beta 6 to install TS and FS. I had to apply this patch because it's not included (you can tell by the absence of the Single Processor Affinity option in the config EXE). TS runs relatively normally, but FS only in skirmish. It fails to read FS campaigns and FS-specific cutscenes unless I remove the no-CD function and use my discs.

 

Also, when saving/loading games when ingame (not in the main menu), the menus behave rather strangely. They show the saved game list on each window refresh, and by the time I want to go to the menu with resume/quit/etc. functions, it shows for a millisecond, then seemingly disappears, while it responds to clicking on wherever the buttons are supposed to be correctly. So much for the testers' QA capabilities.

Share this post


Link to post
Share on other sites

Yea, the patch doesn't work on unofficial installations since those can use a different no-cd patch than the one from TFD/TUC. This is the same problem as with the unofficial TFD patch, the game cannot find the files anymore

 

About the other problem, didn't hear about it yet and have to try to reproduce it

Share this post


Link to post
Share on other sites

When I install the patch, at the end of the install I am receiving an error message saying:

 

Unable to execute file: sdbinst.exe

CreatedProcess failed; Code 5. Access Denied.

 

I am using Windows 10. Anyone know what's going on or has this problem?

Share this post


Link to post
Share on other sites

Didn't hear about this one yet, Access Denied could be caused by security programs or maybe windows 10 has some special security settings to prevent sdbinst from starting up

Share this post


Link to post
Share on other sites

does this fix the freeze with the laser or what was about, the famous internal error "Tiberian sun has encountered an error and cannot be continue"?

Share this post


Link to post
Share on other sites

does this fix the freeze with the laser or what was about, the famous internal error "Tiberian sun has encountered an error and cannot be continue"?

 

No one managed to fix that error yet sadly

Share this post


Link to post
Share on other sites

Download: http://downloads.cncnet.org/TSpatch.exe

 

Features:

Fixed the following error: "A mouse is required for playing Tiberian Sun."

Fixed the following error: "One or more DLL files were missing or damaged. Please reinstall."

Fixed the main menu problems on Windows 8 / 8.1 / 10 ( Black Screen / Invisible Menu / Freezing )

Random freezing can be fixed by setting "Single Processor Affinity" via the config

Graphics Patch

Hyperpatch

Game Launcher

Config Program

Online support via CnCNet with hundreds of players

Final Sun Map Editor

 

Compatibility

The patch has been tested with The First Decade/The Ultimate Collection/Clean CD Install (version 2.03 is required)

Note: The patch is NOT compatible with any other unofficial patches, please make sure you are only using it on a clean official unmodified installation!

The unofficial The First Decade Patch will -not- work in combination with this patch!

 

Windows 7

The menu bug should only occur on windows 8 / 8.1 / 10, if you are running into a similar bug on Windows 7 then the problem is most likely related to broken drivers. Read this for more info: http://cnc-comm.com/community/index.php?topic=3438.msg32933#msg32933

 

I have downloaded the CnCnet installer with FS and map editor..and my menu freezes until I press Esc button and it goes back

Share this post


Link to post
Share on other sites

I have downloaded the CnCnet installer with FS and map editor..and my menu freezes until I press Esc button and it goes back

 

What installer was it? Can you provide the name/link of it? I hope you did not apply this patch linked in here on top of a custom installation, that would not work out too well

 

What windows do you have?

Share this post


Link to post
Share on other sites

I have downloaded the CnCnet installer with FS and map editor..and my menu freezes until I press Esc button and it goes back

 

What installer was it? Can you provide the name/link of it? I hope you did not apply this patch linked in here on top of a custom installation, that would not work out too well

 

What windows do you have?

 

First of all I manged to fix the problem with your patch so Thank You !  :D

I downloaded the Installer from here: http://cnc-comm.com/community/index.php?action=downloads;sa=view;down=41

 

Second of all, I have screen resolution issue like the screen is narrow and not full screen.. I tried to take a print screen but the black space on the sides are gone :/

jb5ow3.png

 

For example

?interpolation=lanczos-none&output-format=jpeg&output-quality=95&fit=inside%7C637:358&composite-to=*,*%7C637:358&background-color=black

 

On Windows 7 I had Display manager for Samsung laptop but I upgraded to Windows 10 Pro 64bit and I have those black panels on the side of the game.

 

Share this post


Link to post
Share on other sites

that looks like you are using a 4:3 resolution on a 16:9 screen maybe, try to change your resolution to 1280x720 in the config program

 

I'm not sure if that old custom installer is fully compatible with my patch, could be that some videos/missions are missing now.

 

If there are any problems then try the latest installer from tore: http://tore29.com/tsins/TSinstaller3-beta10r6.exe

Share this post


Link to post
Share on other sites

that looks like you are using a 4:3 resolution on a 16:9 screen maybe, try to change your resolution to 1280x720 in the config program

 

I'm not sure if that old custom installer is fully compatible with my patch, could be that some videos/missions are missing now.

 

If there are any problems then try the latest installer from tore: http://tore29.com/tsins/TSinstaller3-beta10r6.exe

 

I tried and still the same..

 

2jbjxg7.jpg

Share this post


Link to post
Share on other sites

That looks good, you can see the text in the corners which means the game is using the full resolution. The graphic in the middle is not available in other resolutions so the game ends up centering it. The gameplay should be full screen

Share this post


Link to post
Share on other sites

That looks good, you can see the text in the corners which means the game is using the full resolution. The graphic in the middle is not available in other resolutions so the game ends up centering it. The gameplay should be full screen

 

Yeah I guess you're right.. but I remember on Windows 7 I had Easy Display Manger that I could expend the center resolution and unfortunatly it doesn't works on windows 8

Share this post


Link to post
Share on other sites

Hey FunkyFr3sh, Maybe you can help me out as well.  All I've done is installed TUC on Windows 10(64-it) via Origin.  Then I got the error message which stated it couldn't set the video mode or whatever.  Then I downloaded your patch and now I'm able to launch the game, but then it freezes whenever I try to click anything in the main menu.  Pressing Esc will allow me to manipulate things again, but the menu just keeps freezing whenever I click things.  Any solutions to that?  New launcher needed, perhaps?  Thanks a lot. 

Share this post


Link to post
Share on other sites

hi Starside Ghost, welcome to the forums!

 

Actually the patch should fix exactly the problem you encounter, try to run the patcher again and make sure your security programs are not blocking it.

 

Origin might tell you that there is an update available after you apply the patch, make sure you don't install it! Actually there is no update available, origin only thinks there is one cause the files were modified and don't match the ones on their server.

 

If it still doesn't work then try to add the following into Sun.ini under the [Video] section:

DisableMaxWindowedMode=Yes

 

Did you already test the alternative rendering settings (IE-DDraw, DDwrapper)?

Share this post


Link to post
Share on other sites

Hey, Thanks for the welcome. 

 

I'll try the patch again tonight.  I do remember seeing an error message during patch installation but then it completed anyways and the other Launcher started up so I figured it worked through it.

 

Didn't try any of the rendering settings, just messed with resolution.  I'll let you know what happens tonight.  Thanks a lot.   

Share this post


Link to post
Share on other sites

If the error said something about "sdbinst.exe" then it would explain your problems, cause it would have failed to apply the window 10 fix for the menus

 

yes, keep me updated :)

Share this post


Link to post
Share on other sites

This one I guess?

Unable to execute file: sdbinst.exe

CreatedProcess failed; Code 5. Access Denied.

 

Only heard about it once yet and the guy who had it didn't tell if he was able to get around it, Access Denied could be caused by security programs or maybe windows 10 has some special security settings to prevent sdbinst from starting up

 

You can try to install the compatibility fix manually, you should be able to right click and install:

http://downloads.cncnet.org/Games/TiberianSun/TS.sdb

 

Another option would be to install the TS.sdb via Microsoft Application Compatibility Toolkit

https://www.microsoft.com/en-us/download/details.aspx?id=7352

Share this post


Link to post
Share on other sites

Yep thats the one.  I tried that TS.sdb, there's no option to install when I right click, and I don't know how to use that Compatibility tool kit.  I ran it and it was saying something about SQL servers which, doesn't seem right, but is way over my head so I don't know that its not right.  Thanks for your help, but it might just not happen. 

Share this post


Link to post
Share on other sites

Fair enough, real solution would be finding out why you don't have the needed access on your pc. You might run into this problem again at some point when you install some other programs

Share this post


Link to post
Share on other sites

Heyoooo

 

This is my first post. I downloaded Tiberian Sun from this website (link: http://cnc-comm.com/community/index.php?action=downloads;sa=view;down=41), and when I play I get that menu glitch.. where the menu doesn't open. Alt+Tab makes the menu appear, but it's kind of annoying to have to do that every time I need to see the menu.

So I downloaded this patch in order to fix that issue... but after running it, the program really messes up. The menu glitch still occurs-- and now it asks for a CD!

 

I was reading this thread for an answer, but I didn't really find any solution.

 

I also tried patching with the 2.03 patch [which also causes the CD error (link: http://cnc-comm.com/community/index.php?action=downloads;sa=view;down=29)] and subsequently patching with your patch but it still doesn't work.

 

My laptop runs Windows 7 x 64 bit. So I'm super confused.

If you have any idea how to fix it, let me know!

Share this post


Link to post
Share on other sites

Heyoooo

 

This is my first post. I downloaded Tiberian Sun from this website (link: http://cnc-comm.com/community/index.php?action=downloads;sa=view;down=41), and when I play I get that menu glitch.. where the menu doesn't open. Alt+Tab makes the menu appear, but it's kind of annoying to have to do that every time I need to see the menu.

So I downloaded this patch in order to fix that issue... but after running it, the program really messes up. The menu glitch still occurs-- and now it asks for a CD!

 

I was reading this thread for an answer, but I didn't really find any solution.

 

I also tried patching with the 2.03 patch [which also causes the CD error (link: http://cnc-comm.com/community/index.php?action=downloads;sa=view;down=29)] and subsequently patching with your patch but it still doesn't work.

 

My laptop runs Windows 7 x 64 bit. So I'm super confused.

If you have any idea how to fix it, let me know!

 

This is the old installer, try to get the latest version from here: http://cncnet.org/tiberian-sun

 

But I guess your problems are related to a bugged driver version, check the first post here in this topic for more information

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...