Jump to content

Tiberian Sun patches - Fix for the windows 8 / 10 menu problems and more


FunkyFr3sh
 Share

Recommended Posts

my experience with windows 10 on a new HP 15 lappy

i only play tiberian sun online against other ts players on cncnet5 at this time

first i downloaded the newest version of ts this was a few days ago

i had various issues

i deleted everything cncnet5

then i downloaded http://downloads.cncnet.org/TSpatch.exe from 1st page of this thread

i have been playing without issue

to talk in game i press the fn key on my keyboard then press f8

i use the below settings (in screen shot if im able to put it here if you dont see screen shot i believe clicking ddwrapper is what fixed it) i got to these settings by clicking settings>game settings>config

i also used https://www.youtube.com/watch?v=FQsySYY6MPw to learn how to make windows10 more like 7

 

Screenshot_3.png.9436c6244d907d9b0db6626e6f630ca9.png

Link to comment
Share on other sites

  • 2 weeks later...

Hey!

 

I downloaded the TSinstaller3-beta10r6 and it kinda works. Only problem is, that the buttons are shifted. for example, if I have to choose if I want to play TS or FS, I have to shift the mouse much more to the right to be able to click on them.

 

My display is a 16:9 2560x1440. I tried several different resolutions including the native resolution. Wont work :/

 

Link to comment
Share on other sites

Hey, so I downloaded the patch and installed it successfully, just wondering, is it compatible with TibEd? When I used to play it back when I was a wee little sprout, my dad and I liked to mess around with the attributes of buildings and units on either Nod or GDI, would that still be possible? I've already modified GDI in TSF, but every time I go to run a new Skirmish match, the game freezes up half way through the loading screen, so I'm stuck there with a Titan or an Orca Dropship, and a frozen screen, I can't even bring up Task Manager to try to force kill the program, it's that frozen, so I have to restart my machine every time. Is there something I did wrong, or will I have to remove all current modifications and uninstall TibEd?

Link to comment
Share on other sites

  • 1 month later...

Hi all,

 

My only issue with TS/FS (RA2/YR also) is an in-game menu issue, where I see a silver bar in the middle of the area where the menu is suppose to be. I have to press "Alt+Tab" twice to be able to see the menu(s) as they appear in my client. My game version is TFD w/ unofficial patch 1.03 rev4, installed to a custom directory tree (not enough space on my OS Drive (default install location)). Systems Specs are listed below. I had a workaround in Windows 7 were I could simulate a VGA connection that matched my screen resolution (1366x768) with VideoBackBuffer=no (added to the sun.ini, also in the same file I set the resolution to the max supported for my screen) and I could see the menu(s) ingame. When I updated the OS to Windows 10, I lost the ability to simulate a secondary display again, which put me back to square one :(

 

I understand that the patch in the first post for this game is not compatible with the unofficial 1.03rev4 patch (no-cd patch included), I do have a copy of the game digitally as part of the Ultimate Collection via Origin, but I did not install it because I already have the game installed.

 

A question that I do have for the patch though is as follows: during install can I specify a non-default path if I don't have the space were the install was supposed to be by default?

 

System details:

MSI S6000-017US 15.6" Laptop

OS:: Windows 10 Pro x64

GPU:: Intel Core-i5 HD Graphics (Max Resolution: 1366x768, 1x HDMI and 1x VGA)

CPU:: Intel Core-i5 450M

HDD:: 1.12TB SSD/HDD (single drive case)

ODD:: Super-Multi DVD/CD Burner

 

====================== March 5, 2016 =================================================

Think I fixed my problem for Tiberium Sun by editing the shortcut to force windowed mode in 16-bit colour. Waiting for Red Alert 2 to launch so I can verify the same solution for it, then I will apply and verify the same fix for Yuri's Revenge

Link to comment
Share on other sites

  • 2 weeks later...

I downloaded this patch hoping it would fix the issue that, going into a skirmish match, everything dies. Every unit on both AI and my side. I don't understand why that's happening.

I bought the Origin copy of the Ultimate Collection so I definitely shouldn't be getting this through the anti-pirate system, is it just something that happens?

Link to comment
Share on other sites

  • 3 weeks later...

Did the videos work before you applied the patch? What windows do you have? What TS installation do you have (First Decade/Ultimate Collection/Old CD's)?

Hi. I got the game off CnCNet and it still asks for a CD when I press single player.

I have windows 7 and also downloaded your patch and clicked on cncnet5.exe which then downloaded more stuff.

What should I do, is there any way to play the missions?

Thanks!

Link to comment
Share on other sites

  • 1 month later...

I have a different kind of issue with game. When i turn in on, and try to record it using FRAPS it gets crash. I can't even beat first GDI mission because of that. I tried many different options, many configurations - no results. When i'll get back home i'll try upload error message that pops-up right after crash.

 

Cheers!

Link to comment
Share on other sites

I'm not sure if this issue was covered in computer language already or not, but my computer installed windows 10 (without my knowledge) and now when i try to play ts, there is a horrid stop-and-go type of lag that forces me to surrender due to how awful it is. does anyone have a remedy for this?

Link to comment
Share on other sites

Hi

i've installe TiberianSun_Online from the website

So i was installed in C:\Games\CnCNet\TiberianSun_Online\

do i need to installe the patch in C:\Westwood\SUN or i need to change it to  C:\Games\CnCNet\TiberianSun_Online\  ?

Sorry for my bad english ,

best regards ;)

Link to comment
Share on other sites

  • 1 month later...

I'm not sure if this issue was covered in computer language already or not, but my computer installed windows 10 (without my knowledge) and now when i try to play ts, there is a horrid stop-and-go type of lag that forces me to surrender due to how awful it is. does anyone have a remedy for this?

 

I'm having this problem too!

 

Also, does anyone have problems where everything works fine but when you use 6 or 7 players on a LAN occasionally you'll lose connection with someone?  Normally our 7 or 8 players are 4 people and 2 or 3 AI. It seems that it crashes when ALOT of units are being moved at the same time (e.g. several of us attacking an AI player at the same time)

Link to comment
Share on other sites

Hi

i've installe TiberianSun_Online from the website

So i was installed in C:\Games\CnCNet\TiberianSun_Online\

do i need to installe the patch in C:\Westwood\SUN or i need to change it to  C:\Games\CnCNet\TiberianSun_Online\  ?

Sorry for my bad english ,

best regards ;)

 

You should never use TSpatch for any custom installations like the mini online version, it was only made for those using the official installation (First Decade, Ultimate Collection or old CD's)

 

 

I'm not sure if this issue was covered in computer language already or not, but my computer installed windows 10 (without my knowledge) and now when i try to play ts, there is a horrid stop-and-go type of lag that forces me to surrender due to how awful it is. does anyone have a remedy for this?

 

I'm having this problem too!

 

Also, does anyone have problems where everything works fine but when you use 6 or 7 players on a LAN occasionally you'll lose connection with someone?  Normally our 7 or 8 players are 4 people and 2 or 3 AI. It seems that it crashes when ALOT of units are being moved at the same time (e.g. several of us attacking an AI player at the same time)

 

After the update to windows 10 you will have to re-download the game from our site and do a fresh installation, every windows needs different settings and the installer will detect your windows version to apply the correct settings.

 

Are you getting a "recon" error? That happens quite often when there are a lot of units on the map, especially when you play with AI players, there is sadly no solution for it yet

Link to comment
Share on other sites

Is there a way to get this to stretch the graphics to fit the new resolution instead of just zooming the game out?

 

Also I am trying to get this game to run windowed but i am having a lot of problems with any rendering method besides default. Either it flickers, scrolling up has insane speed (only up), and/or the larger the window the slower the game. Is there any sort of guide for configuring this?

Link to comment
Share on other sites

Is there a way to get this to stretch the graphics to fit the new resolution instead of just zooming the game out?

 

Also I am trying to get this game to run windowed but i am having a lot of problems with any rendering method besides default. Either it flickers, scrolling up has insane speed (only up), and/or the larger the window the slower the game. Is there any sort of guide for configuring this?

 

There is no zooming option right now, do you have a problem where the game starts small surrounded by black if your game resolution doesn't match your native res? In that case you can enable stretching in your graphic card driver settings.

 

The patcher was updated recently, window mode should be working fine now. But you need to remove the compat fix from the old installation, it is named "TiberianSunCompatFix" - https://www.google.com/search?q=how+to+uninstall+a+program

Link to comment
Share on other sites

  • 3 weeks later...

Downloaded game (single player campaign) from this site.

Default install.

Game runs initially fine on windows 10.

Good menus,no black screen etc.

After some time (10 min) game freezes and have to reboot laptop.

 

Trying to avoid this freezing I downloaded and installed patch.

Again default install.

Now I don't see anything but black screens.

 

Any advice to run game on W10 without black screens and annoying freezes?

Am I doing something wrong with this patch?

Link to comment
Share on other sites

  • 3 weeks later...

Hello again,

 

I've downloaded Tiberian Sun off this website and installed it.  It is much more stable and playable than The First Decade version i was trying to play before. I only have 1 problem.  When I try to load a savegame it honestly takes almost 2 minutes to load.  Anyone else experience this?  Anyone found a way to fix it? 

 

Paul

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...