Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
FunkyFr3sh

Tiberian Sun patches - Fix for the windows 8 / 10 menu problems and more

Recommended Posts

Downloaded patch to windows 10, saved it under "C:\Program Files (x86)\Origin Games\Command and Conquer Tiberian Sun"

and whenever I try and start the game its only a black screen. I can hear all of the effects and still press buttons but I cannot see anything except a black screen.

Share this post


Link to post
Share on other sites

Downloaded patch to windows 10, saved it under "C:\Program Files (x86)\Origin Games\Command and Conquer Tiberian Sun"

and whenever I try and start the game its only a black screen. I can hear all of the effects and still press buttons but I cannot see anything except a black screen.

 

Did you download + double click TSpatch to install it or did you only place it in the game folder?

 

Apply the patch again. If origin tells you there is an update available for the game, DO NOT install that update (It will revert all changes from TSpatch)

Share this post


Link to post
Share on other sites

Downloaded patch to windows 10, saved it under "C:\Program Files (x86)\Origin Games\Command and Conquer Tiberian Sun"

and whenever I try and start the game its only a black screen. I can hear all of the effects and still press buttons but I cannot see anything except a black screen.

 

Did you download + double click TSpatch to install it or did you only place it in the game folder?

 

Apply the patch again. If origin tells you there is an update available for the game, DO NOT install that update (It will revert all changes from TSpatch)

 

 

My bad for miscommunication, I installed the patch to "C:\Program Files (x86)\Origin Games\Command and Conquer Tiberian Sun" and when clicked offline got a black screen with the opening Westwood noises. All the buttons worked just nothing on screen. I installed patch a few times and even turned off the auto updates for the game. Gonna try unistalling ts then try again

Share this post


Link to post
Share on other sites

I guess you might have a special problem (not the usual win 8 / 10 bug)

 

Try to switch the rendering options in the config program. ddwrapper+directdrawemulation might be good or DxWnd (Try window mode too)

Share this post


Link to post
Share on other sites

I guess you might have a special problem (not the usual win 8 / 10 bug)

 

Try to switch the rendering options in the config program. ddwrapper+directdrawemulation might be good or DxWnd (Try window mode too)

 

thankyou so much for all your help! Switched it to the ddwrapper+directdrawemulation and it worked fantastic. very much appreciate the quick responses and helpful feedback. 10/10 will go tell a friend

Share this post


Link to post
Share on other sites

Ok, so I installed my CD, installed the 2.03 patch.

I opened the game no problem but then when I clicked on any of the menu options it would freeze.

So I downloaded this patch, and now the launches but is just a black screen and I can see my cursor.  :mad:

Do you know how I can fix this?

 

I have windows 10

Share this post


Link to post
Share on other sites

Ok, so I installed my CD, installed the 2.03 patch.

I opened the game no problem but then when I clicked on any of the menu options it would freeze.

So I downloaded this patch, and now the launches but is just a black screen and I can see my cursor.  :mad:

Do you know how I can fix this?

 

I have windows 10

 

try to play around with the rendering options in the tiberian sun config program, ddwrapper+directdrawemulation could work or DxWnd

Share this post


Link to post
Share on other sites

Just created an account to thank you for the patch. I can finally play this game now :)

 

Great to hear you got it working now! Thanks for the feedback

Share this post


Link to post
Share on other sites

Great Patch. Made me able to play my most favourite game again. Thank tons guys. But one problem. When I try to minimize the game it never opens up again. I can hear the game running and all but the window just stuck to the small bar in the left top corner. And I if some window like skype or steam pops up it will be blinking on my game screen no stop. Any way to fix this?

Share this post


Link to post
Share on other sites

Great Patch. Made me able to play my most favourite game again. Thank tons guys. But one problem. When I try to minimize the game it never opens up again. I can hear the game running and all but the window just stuck to the small bar in the left top corner. And I if some window like skype or steam pops up it will be blinking on my game screen no stop. Any way to fix this?

 

It's a known problem on windows 8 and 10. There are multiple workarounds, but non is perfect yet.

 

Enable DxWnd in the config program

or

Enable DxWnd + run in window in the config program

or

Enable Rendering Default + run in window in the config program

 

 

You can also try to play around with the other rendering settings, takes a bit of tweaking but you might get acceptable results.

IE-DDraw can work for example, but it has a bad performance. TS-DDraw can work too, but it seems to crash often on windows 10

 

Share this post


Link to post
Share on other sites

Hi guys,

 

just refound my ts and thought: winter + ts = couple of mission play.

 

However these days I'm running windows 10 and was glad to find this patch to run the game. However my "mod files" (rules.ini) to get units that are usually not buildable ingame don't take any affect anymore. Any ideas why that's the case? Even if I update the MIX there's no difference.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I was unaware that there were other versions of TS available nowadays, so I sent a friend to the old archived fileplanet mirror.

 

My friend is on a windows 7 install and is now getting an "r6030 crt not initialized" runtime error after applying this due to a previous error(He's run the included tfd registry).

 

Running cncnet5.exe yields a failed update.

 

He wishes to use the utility, although you say it's not required for 7, for borderless window support.

 

How best shall we proceed?

Share this post


Link to post
Share on other sites

I'd suggest... erasing everything, and downloading the full campaign installer from the cncnet site? It's under "View All Downloads".

 

Hey Funky, does the cncnet downloads' full version still require this patch? I've never really gotten any clear answer on that I think. - [edit] Turns out that, nope, it doesn't  8)

 

And why is that download called "single player campaign" anyway? Makes it sound like an addon for another download instead of the whole game. Even if it's not compatible with cncnet, then just call it "Full game (single player only)"

Share this post


Link to post
Share on other sites

Hi all, I recently installed the ultimate collection version, and downloaded the patch from this thread, so it runs now, but I am having an issue with the scroll speed.  It seems to be dialed up to 11 all the time, and I cannot accurately control it because it a half second to send the screen flying to the extreme edge.  Is there anything that I can do to fix this?  Any help would be appreciated.

Share this post


Link to post
Share on other sites

Hi all, I recently installed the ultimate collection version, and downloaded the patch from this thread, so it runs now, but I am having an issue with the scroll speed.  It seems to be dialed up to 11 all the time, and I cannot accurately control it because it a half second to send the screen flying to the extreme edge.  Is there anything that I can do to fix this?  Any help would be appreciated.

 

Did you try scrolling with the right mouse button?

 

You can switch the renderer to "Default" in the config program, it should make it a bit slower. If it's still to fast, try to disable the "Graphics Patch" too.

 

You can also play around with the other rendering settings, dxwnd and ie-ddraw could work fine too

Share this post


Link to post
Share on other sites

I did try scrolling with the right mouse button, it does the same thing.  I will try your suggestions and see how they work, hopefully it will work.  I will let you know.

Share this post


Link to post
Share on other sites

So I did what you suggested and it worked.  I can now play the game without zooming across the screen. Thank you.

Share this post


Link to post
Share on other sites

Hey, just wanted to say thanks for making this! Enjoyed revisiting these classic games.

 

The Tiberian Sun campaign worked without issue, but unfortunately I am having an issue with Firestorm.

 

My details:

Game: http://tore29.com/tsins/TSinstaller3-beta11r6.exe

Patch: https://downloads.cncnet.org/TSpatch.exe

Windows 10 64 bit

Geforce 770

 

So, the Firestorm screen comes up no problem, but when I try to start a new campaign, there is an error: "Unable to read scenario!" However, if I try a fresh install without TSpatch, I can start a new campaign in Firestorm just fine, but there are tons of menu issues and game crashes. Also, I started the campaign without the TSpatch, saved a game, then applied the patch, and everything worked great until the mission ended, at which point I got the unable to read scenario error again.

 

Any ideas?

Share this post


Link to post
Share on other sites

Hi!

 

You cannot apply TSpatch on custom installations like TSinstaller3-beta11r6.exe since it comes with its own compatibility fixes and settings.

 

TSpatch is only for official unmodified installations like the first decade or the origin version.

 

 

To solve your problem with the menus you'll have to play around with the rendering settings, try IE-DDraw

Share this post


Link to post
Share on other sites

Ah, ok, thanks for the clarification. For some reason none of the rendering settings in TSinstaller3-beta11r6 worked for me reliably. For example, ddwrapper with directdraw emulation worked with TSpatch, but not with TSinstaller3.  :S

 

Anyway, snagged a version from the first decade and applied this patch and Firestorm works now, cheers!

Share this post


Link to post
Share on other sites

Has anyone encountered a false positive with the exe FinalSun.exe? My comodo anti virus detected this file as a trojan downloader so I eliminated it and uninstalled the game just to be safe.

 

I doubt it's a trojan because I've had this computer for over a year and never had any of my accounts compromised. Can anyone give me clarification? It detected it as [email protected]

Share this post


Link to post
Share on other sites

Has anyone encountered a false positive with the exe FinalSun.exe? My comodo anti virus detected this file as a trojan downloader so I eliminated it and uninstalled the game just to be safe.

 

I doubt it's a trojan because I've had this computer for over a year and never had any of my accounts compromised. Can anyone give me clarification? It detected it as [email protected]

 

I just checked it quick on virustotal and you are right, comodo is showing a false positive detection while all other 57 anti virus programs claim the file is clean (yes, it is clean!)

 

The result is here:

https://virustotal.com/en/file/f129c8db9311063d06924e3b935ff61a59ac2b66950354b2c4406762a4728349/analysis/1488165732/

 

 

I guess someone needs to file a report just to let the comodo guys know about the problem so they can fix it

Share this post


Link to post
Share on other sites

Hi!

 

You cannot apply TSpatch on custom installations like TSinstaller3-beta11r6.exe since it comes with its own compatibility fixes and settings.

 

TSpatch is only for official unmodified installations like the first decade or the origin version.

 

 

To solve your problem with the menus you'll have to play around with the rendering settings, try IE-DDraw

 

Ahhh! Noob here. So the TSpatch only applies to multiplayer?

 

I thought TSinstaller3-beta11r6.exe is official because I downloaded it from cncnet.org. I think it seems so for most external visitors. Is there a way to clarify the file hotlink in the download page?

Share this post


Link to post
Share on other sites

Hi!

 

You cannot apply TSpatch on custom installations like TSinstaller3-beta11r6.exe since it comes with its own compatibility fixes and settings.

 

TSpatch is only for official unmodified installations like the first decade or the origin version.

 

 

To solve your problem with the menus you'll have to play around with the rendering settings, try IE-DDraw

 

Ahhh! Noob here. So the TSpatch only applies to multiplayer?

 

I thought TSinstaller3-beta11r6.exe is official because I downloaded it from cncnet.org. I think it seems so for most external visitors. Is there a way to clarify the file hotlink in the download page?

 

TSpatch is mainly for single player installations (First Decade / Origin / Official CD's from back in the day)

 

 

Oh I was not referring to "official cncnet", but you are right, I need to make this more clear!

 

The TSinstaller and TSpatch "should" have the same functionality and there is no need to apply TSpatch on top of the TSinstaller. Both are unofficial fan made.

 

Official = Origin / The first decade

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...