Jump to content
  • 0

Allied Campaign opens weird game



I reinstalled Red Alert 2 and got it working on Windows 10. Along the way I did something, modded it in some way, and everything works fine except for the Allied Campaign which starts a game with the instruction:

The terrorist that captured Tanya, Pablo Ochoa, lives inside this camp.

Objective 1: Kill P. Ochoa

Objective 2: Destroy the modified V3 rockets.

Objective 3: Escape.

I would really like to replay the Allied campaign for nostalgia's sake. I tried playing the game and it proved impossible in that I achieved all the objectives (which wasn't easy!) but the game didn't end. Unfortunately I played skirmishes for a while before thinking to try the campaigns and I've forgotten what I did that caused this mess.

Has anyone come across this? I tried to do a repair install of C&C The First Decade, but the install program points to the DVD drive not the installation hard-disk. This also stops me easily uninstalling the program. My next option is to manually delete the program files and then start messing around with the registry... not my first choice.

I've attached three jpeg files showing the weird game.

Any help gratefully received.


RA2 Strange Allies Campaign 1.jpg

RA2 Strange Allies Campaign 2.jpg

RA2 Strange Allies Campaign 3.jpg

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

This is an allied fan mission called commandos

There should be 3 files called:




You should find these 3 files in your red alert 2 directory select them and delete them from your folder that should restore the allied original campaign.

Link to comment
Share on other sites

  • 0

Thanks, deleting those three files means that the objectives are now correctly listed for an Allied campaign, but it still runs the commandos fan mission. I'll start moving other files to see whether I can find which one is still causing problems. I may have to reinstall from scratch😀

Link to comment
Share on other sites

  • 0

I suggest you to run the uninstaller, first CnCNet if you have it (unins000.exe) and then Ra2YR (uninstall.exe) or from the ADD/REMOVE Programs in your CP.

It will remove all the Ra2 and YR essential files, and keep what you added later (maps and stuffs). Once you get there, rename that folder to Ra2Backup or something like that and start a fresh install from the discs or EA App, installing the CnCNet and all the stuff and fixes.

Now go to your backup folder and copy only what you really are going to use to the main folder, and of course avoid the allxxx.map and sovxxx.map files if there's any to avoid overwriting.

Tell me if it worked ;)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...