Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
TPT

Tiberian Sun | Pink/Black screen on load and play

Question

On 1st August 2018 i tried to play online and on Skirmish. After setting games up (on both custom and standard maps) and launching, the load screen and subsequent gameplay would be purple and black with the resolution not quite as usual. This makes the game unplayable :(. My brother also experienced this on his laptop.

I have just tried again on Skirmish (Aug 3) and am experiencing the same problem. We both have Macs (relatively new, top condition) and have not tweaked any settings at all.

Have attached a screenshot to help (below).

Anyone know why this is and what the solution or fix is?

image.thumb.png.2b4e47b98e538b02a206f76b2cfa4418.png

Edited by TPT
clarity that its not just isolated to me

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

ūüôąafter trying all sorts of combos, simply changing/experimenting with¬†the resolution has managed to fix it;¬†I'm a little more zoomed out (actually beneficial for my smaller screen laptop), but this seems to have solved the issue. I can play again :)¬†!!!!!!!!!!!

All very strange as the issue occurred¬†randomly after months of perfect gameplay. So glad its sorted¬†ūü§™

 

Thanks for all your help

Share this post


Link to post
Share on other sites
  • 0

How did you install?

If you have cncnet installed then use it to go online to force an update and then go in to Tiberian Sun setting from the cncnet client and set the renderer to Automatic.

If you don't have cncnet installed then install this https://downloads.cncnet.org/TSpatch.exe and do the same as above.

Share this post


Link to post
Share on other sites
  • 0

This is the old 16bit color depth game running on a 32bit color depth screen problem. Normally that only happens in windowed mode, never in fullscreen. Are you running the game in a window?

 

Setting the renderer to Automatic should solve the problem.

 

Are you using the porting kit or our cncnet.app?

Share this post


Link to post
Share on other sites
  • 0

This is what i am using

image.thumb.png.bbc703cdbdb784a6ca51722b26d5d677.png

 

I have tried going online and getting the updates. When i set the renderer to automatic and try and launch a game i just get a black screen... i waited but my laptop forced itself onto my login screen and then everything had disappeared. I then heard the surrender sequence (from the game lol) about 5 minutes later. no idea where this came from.

Share this post


Link to post
Share on other sites
  • 0

Can confirm when i use full screen and automatic it simply shows a black screen and then my mac force closes all applications and shows my login screen.

Share this post


Link to post
Share on other sites
  • 0

Go into the skirmish or online lobby and then type this into the textbox:

/install ts-config

 

Now open the config program and try display mode = windowed and renderer either GDI or Automatic

Share this post


Link to post
Share on other sites
  • 0

Cool, so what are the exact settings you're using now? Maybe it can help others who got the same problem too.

Did the windowed mode actually work or you didn't try?

 

 

BTW, I just updated the macOS download and it got the full single player campaign for tiberian sun now too.

In case you are interested, get it here: http://funkyfr3sh.cnc-comm.com/files/CnCNet.dmg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Mythos91
      Hi there.
      I am working on my second Singleplayer Mission for Tiberian Sun but I have hit a snag. It won't load it gets to "involving factions" in the level loading list and an internal error pops up. I thought I had set up the Houses correctly?
      The layout of the map is done and I have done most of the trigger work finished ready to test but it won't load up.
      Could anybody help us out. Please?
      Regards.
      nodmission2.map
    • By HandlessCacti
      I can get onto Tiberian Sun multiplayer fine but when I press start it logs me out of my computer I then log in and can hear everything happening but everything is as if id just logged on and I can't find it when I press command option escape to see my apps. how can this be fixed so that I can play?
       
    • By NHG(N_HuyGamingVN)
      Someone help me how make Ai attack in Final Sun Singleplayer Mission
    • By hosin
      I was connecting to the TS game lobby through cncnet, and found that i entered the chatting channel of RA. The rooms shown on the left is for TS, but the chat room in the middle isfor RA. Do they share the channel or how can I fix the problem?
    • By JPlay1
      Hello all!

      I downloaded one of the maps here and put the .mpr into my folder ".../TiberianSun/maps/custom". Also tried only /maps. I can choose it neither in skirmish nor in an online lobby. Map list just looks like always.

      TS is from Origin with CNCnet TSpatch installed.
       
      Need help!
      Ty
  • Recently Browsing   0 members

    No registered users viewing this page.

×