Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...

How do I make thee AI build a huge base?

Recommended Posts

I'm trying to make a super difficult AI to fight. I tried editing the rules.ini section like WarFactoryLimit = 100, or something like that with all the structures. But it doesn't build more than a certain number of structures. How would I make it build say, 10 refineries? I've been searching alot and haven't found any answer. Thanks for your help.

Share this post

Link to post
Share on other sites

I guess it is this entry:

BaseSizeAdd=99           ; computer base size can be no larger than the largest human opponent, plus this quantity


Which game?

Share this post

Link to post
Share on other sites

Oh, Tiberian Sun. I tried exactly that - adding 99. It didn't seem to work.

Edit: Sorry for the delay, my posts seem to need moderator approval before posting.

Edited by Contra

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Excalibur
      I have a problem in displaying units. When I start the game, there are around 20 infantry soldiers that are not being displayed. It is actually hard to find them, you can see it only when you want to deploy a building and then there's that red square showing something is already there. Then when you put your pointer (mouse) there, you can see  soldier's health and you are able to click on it and move it. But you cannot see them. It's not working even if you choose a command to select all units. More, when you sell buildings, all the soldiers turn into ''ghosts'' just like some infantry at the start of the game. The problem however is ONLY in light infantry unit, it's not seen even if it's trained and the same goes for enemy light infantry units, they are invisible.
      Can anyone help me resolve this issue please?
      Thanks a lot
    • By IntoTheRain
      I have a few questions about basic TS modding that  I was hoping someone here could help with.

      1) Is it possible to enforce hard tech requirements for units?  IE continually check to see if you have the Radar you need for that MLRS?  Or the Tech Center you need for that Stealth Tank?

      2) Is it possible to build new units with units already starting inside?  For example, if I wanted the APC to spawn with 5 rifles inside it?

      3) Is there a control that you can set to prevent a unit from being hijackable? Maybe I just don't see it in the rules.ini, but I'm assuming something like that has to be there.

      4) Has anyone gotten a multipad airfield to work like in the RA2 and later games?  Also, is it possible to enforce a 1 aircraft per helipad limit like with RA2 and beyond?  I know Aircraft were limited to 1 an airfield in RA1, so I'm assuming the logic is still there somewhere, I just don't know where to look.

      5) Is there a good way to get a handle on how much damage the Devil's Tongue / GS / MMII / Disrupter do?  The after damage affect seems really convoluted.  I believe the railguns are 150/200 for the GS/MM2 respectively, but the other two are harder to get a fix on.
    • By midatou
      I'm trying to install tiberian sun cncnet on Linux/Kubuntu 18.04.11 TLS.
      The .deb package won't install, it says unable to meet dependencies. I see on the installation video that linux mint seems to resolve the dependencies, perhaps its kubuntu?
      When I run it in a terminal it forces me to remove PHP (which I am running a server, so I don't want to uninstall php!).
      How do I install cncnet? I am still new to linux but am loving it so far.
      Is there any way to install it without removing php? Seems wine requires its removal to install. Why -- anyone know?
      Perhaps I can install on another account or? Maybe cncnet needs to look into using .AppImages -- they are pretty easy and OpenRA uses them perfectly for RA, TD, and Dune and they work great.
    • By BenjaTG
      When I want to play online, it appears that I could not update, and I already deactivated the anti virus and the firewall and it stays the same, what do I do?
    • By 11kgm
      Hey All,
      Windows 10 did an update that murdered my computer and i was halfway through a command and conquer binge.
      I installed Tiberian Sun and went to play it and got the menu freezes error. I have tried two unofficial patches, and they won't even start up the game anymore, tried running it in compatibility modes, tried running as administrator, tried deleting files/adding files and can't get it working.
      Before the update no issue everything worked and was having a grand old time, since the update and my computer dying i have had nothing but issues.
      So is there any last solutions to get this bad boy back up and running?
  • Recently Browsing   0 members

    No registered users viewing this page.