Jump to content
  • 0

RAYR wont start up


willson
 Share

Question

Hi, 

Since there is no support for catalina i've installed bootcamp with Windows 10. Downloaded my original games from Origen and installed CNCnet. 

When I start de origen version of the game it works. 

When i Start the CNCnet version to play online, it throws me an error. 

 

This is the content of my client.log

 

14.05. 08:26:35.763    ***Logfile for Yuri's Revenge client***
14.05. 08:26:35.779    Client version: 2.6.2.6
14.05. 08:26:35.779    Loading settings.
14.05. 08:26:35.935    Initializing updater.
14.05. 08:26:35.935    Update mirror count: 1
14.05. 08:26:35.935    Running from: clientdx.exe
14.05. 08:26:35.951    Operating system: Microsoft Windows NT 6.2.9200.0
14.05. 08:26:35.951    Selected OS profile: WIN810
14.05. 08:26:35.951    Removing partial custom component downloads.
14.05. 08:26:35.951    Checking for the existence of FinalSun.ini.
14.05. 08:26:35.951    FinalSun.ini doesn't exist - writing default settings.
14.05. 08:26:35.951    An exception occured while checking the existence of FinalSun settings
14.05. 08:26:35.951    Writing installation path to the Windows registry.
14.05. 08:26:36.756    Initializing GameClass.
14.05. 08:26:36.964    InitGraphicsMode: 5120x2880
14.05. 08:26:36.974    KABOOOOOOM!!! Info:
14.05. 08:26:36.984    Message: HRESULT: [0x80070057], Module: [General], ApiCode: [E_INVALIDARG/Invalid Arguments], Message: De parameter is onjuist.

14.05. 08:26:37.004    Source: SharpDX
14.05. 08:26:37.004    TargetSite.Name: CheckError
14.05. 08:26:37.004    Stacktrace:    bij SharpDX.Result.CheckError()
   bij SharpDX.DXGI.SwapChain.ResizeBuffers(Int32 bufferCount, Int32 width, Int32 height, Format newFormat, SwapChainFlags swapChainFlags)
   bij Microsoft.Xna.Framework.Graphics.GraphicsDevice.CreateSizeDependentResources()
   bij Microsoft.Xna.Framework.Graphics.GraphicsDevice.Reset()
   bij Microsoft.Xna.Framework.Graphics.GraphicsDevice.Reset(PresentationParameters presentationParameters)
   bij Microsoft.Xna.Framework.GraphicsDeviceManager.ApplyChanges()
   bij Rampastring.XNAUI.WindowManager.InitGraphicsMode(Int32 iWidth, Int32 iHeight, Boolean bFullScreen)
   bij DTAClient.DXGUI.GameClass.SetGraphicsMode(WindowManager wm)
   bij DTAClient.DXGUI.GameClass.Initialize()
   bij Microsoft.Xna.Framework.Game.DoInitialize()
   bij Microsoft.Xna.Framework.Game.Run(GameRunBehavior runBehavior)
   bij DTAClient.Startup.Execute()
   bij DTAClient.PreStartup.Initialize(StartupParams parameters)
   bij DTAClient.Program.Main(String[] args)
14.05. 08:26:37.314    Hardware info: Intel(R) Core(TM) i5-7500 CPU @ 3.40GHz (4 cores) | Video controller: Radeon Pro 570 | Total physical memory: 16GB

 

 

Any advice would be appreciated.

error.PNG

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0
12 hours ago, dkeeton said:

try to change the settings in RA2MD.ini, under the [Video] header add or change
 

[Video]
ClientResolutionX=3840
ClientResolutionY=2160

Or some other smaller resolution that's tolerable.

Sadly doesn't work for me at least.

Link to comment
Share on other sites

  • 0

After updating my drivers the issue reappared again. Still looking for permanent solution.

 

Found out that if I change my settings to use 640 x 480 from the compatiblity tab, its works (but screen is al foggy)

Edited by willson
Link to comment
Share on other sites

  • 0

I've fixed it by change this in de RA2MD.ini

 

[Video]
ForceLowestDetailLevel=False
Video.Windowed=False
NoWindowFrame=False
ClientResolutionX=2560
ClientResolutionY=1440
BorderlessWindowedClient=False
UseGraphicsPatch=False
VideoBackBuffer=False
ScreenWidth=2560
ScreenHeight=1440
StretchMovies=no

Link to comment
Share on other sites

 Share

×
×
  • Create New...