Dan9550

Tiberian Sun, Windows 8

93 posts in this topic

Ok so from googling a bit it looks like no one else has ever seen, or found out about this issue yet. But Tiberian Sun (also RA2) suffers from severe lag in Windows 8 which can be fixed by the CnC Graphics Patch. But Tiberian Sun also has a strange issue where you cannot see the menus. You can start the game pick either firestorm etc. But you can't see any menus that are not the main menu, essentially makes the game unplayable.

 

Although you can start a skirmish if you just hit enter after clicking Skirmish on the main menu, but the options for skirmish and "esc" menu in game all are just invisible. Anyone got any ideas?

0

Share this post


Link to post
Share on other sites

Are you able to post some screenshots so we can see visually? I guarantee someone will stop by to help but this is a good start.

0

Share this post


Link to post
Share on other sites

Here is a short video which shows the issue, the only control i have on these invisible menu screens is "esc" to go back and "enter" to continue xD

 

http://youtu.be/dDZ_H0HhBjo

 

Also i will list my system specs here, and this game worked fine on this same system running Windows 7.

 

AMD Phenom II X2 555 @ 3.2Ghz

8GB DDR3-1333

nVidia GeForce 9800GTX+

ASUS Xonar D1

0

Share this post


Link to post
Share on other sites

Here is a short video which shows the issue, the only control i have on these invisible menu screens is "esc" to go back and "enter" to continue xD

 

http://youtu.be/dDZ_H0HhBjo

 

Also i will list my system specs here, and this game worked fine on this same system running Windows 7.

 

AMD Phenom II X2 555 @ 3.2Ghz

8GB DDR3-1333

nVidia GeForce 9800GTX+

ASUS Xonar D1

 

Where did you download Tiberian Sun?

0

Share this post


Link to post
Share on other sites

I didn't download it i installed it from my First Decade disc then applied the unofficial 1.03 patch.

0

Share this post


Link to post
Share on other sites

Nope... seems like a weird issue.

 

 

 

This may seem like an odd question, but did you update your video drivers to the latest version? Stuff like that MAY help.

0

Share this post


Link to post
Share on other sites

Pretty sure that PC has nVidias 300 drivers of some version. I'll check later on and update them if there is something newer and try again.

0

Share this post


Link to post
Share on other sites

Had this issue before on a netbook. Just gave up really. Couldnt find the fix, happens on some computers and not on others.

0

Share this post


Link to post
Share on other sites

Ok, so im using the latest nVidia Drivers 302.Somthing. This time with a GTX 460 not the 9800GTX+ (same PC) i get the same result, im going to try it out on another PC i have running windows 8 the main difference being that is GPU is a AMD.

 

and yes i have the graphics patch applied.

0

Share this post


Link to post
Share on other sites

Ok so i have tested it on the following systems all with the same issue.

 

System 1:

AMD Phenom II 965

16GB RAM

nVidia GTX460 SLi

Windows 8 Consumer Preview

 

System 2A:

AMD Phenom II 555

8GB RAM

nVidia 9800GTX+

Windows 8 RTM

 

System 2B:

Same as 2A but with nVidia GTX460

 

System 3:

AMD A8-3870K

8GB RAM

HD 6550D (Integrated in APU)

Windows 8 RTM

0

Share this post


Link to post
Share on other sites

Yea, this is a serious OS level issue and effects windows 7 as well.

 

What version of windows 7/8 are you guys using?

0

Share this post


Link to post
Share on other sites

Well... That seems that we will need to get some stuff back from Wine...

 

Did you guys test with Windows XP to make sure if it is really 7/8 related?

0

Share this post


Link to post
Share on other sites

Well i have never had this happen on Windows 7 i have seen Tiberian Sun run fine on at least 5 Windows 7 PCs. It's just with Windows 8 i have had this issue.

0

Share this post


Link to post
Share on other sites

Ok so i was messing with Twisted Insurrection (mod for Tiberian Sun) and i was able to get the game in a somewhat closer to playable state.

 

I enabled 16-bit colour in the compatibility tab for the TI_Launcher, and ran the game in windowed mode (fullscreen still suffers from mission menus) apart from the lag which maybe could be fixed with the CnC Graphics Patch. (and the fact that the game is windowed) It's all running well, so this is closer to being playable on windows 8.

0

Share this post


Link to post
Share on other sites

Ok so i was messing with Twisted Insurrection (mod for Tiberian Sun) and i was able to get the game in a somewhat closer to playable state.

 

I enabled 16-bit colour in the compatibility tab for the TI_Launcher, and ran the game in windowed mode (fullscreen still suffers from mission menus) apart from the lag which maybe could be fixed with the CnC Graphics Patch. (and the fact that the game is windowed) It's all running well, so this is closer to being playable on windows 8.

 

And then the system report an APPcrash

 

Problem signature:

  Problem Event Name: APPCRASH

  Application Name: game.exe

  Application Version: 1.0.0.1

  Application Timestamp: 393c1b12

  Fault Module Name: game.exe

  Fault Module Version: 1.0.0.1

  Fault Module Timestamp: 393c1b12

  Exception Code: c0000005

  Exception Offset: 0008b3cb

  OS Version: 6.2.9200.2.0.0.400.8

  Locale ID: 1033

  Additional Information 1: b388

  Additional Information 2: b388a55ecf1da73a087f5a17f5e2106d

  Additional Information 3: 030a

  Additional Information 4: 030a589d228e162d8b751822258b9644

 

Read our privacy statement online:

  http://go.microsoft.com/fwlink/?linkid=190175

 

If the online privacy statement is not available, please read our privacy statement offline:

  C:\Windows\system32\en-US\erofflps.txt

 

But I have not find anyway to solve this.

0

Share this post


Link to post
Share on other sites

Hi,

 

I spent all day trying to get this going.  C&C First Decade is my son's favourite game.  I have upgraded to Win8, and gotten almost everything reinstalled.  Red Alert, Renegate, RA2, Generals, and Zero Hour all work.  Yuri has some lagging I am trying to fix, and Tiberian Sun has exactly the problem described here.  It launches fine, but the menus simply won't come up.  I can get the game to launch by hitting ENTER on New Campaign, but then I have no way to save it.  I think I know why it is doing this.  Win8 forces the desktop into 32-bit mode, you can't go into 16-bit mode any longer.  I am guessing the second layer of menus in Tiberian Sun require 16-bit colour, else they won't load.  I tried that Twisted Insurrection workaround listed above, but couldn't get it to work.  It won't force 16-bit mode, it just does a lot of crashing.

 

Anyone have any other ideas?

 

Thanks,

DD.

0

Share this post


Link to post
Share on other sites

Hmm... can you still disable Aero on Win8? If so that may stop it.

 

I thought Win8 had a compatibility mode to disable Areo, though.

0

Share this post


Link to post
Share on other sites

:ranting: :ranting: :ranting: :ranting: :ranting: :ranting: :ranting: :ranting: :ranting: :ranting: :ranting:I play ts firestorm in windows 8 and I get the same problem.I think is because this is a new os so it should be lagging. ;) ;) ;) ;) ;) ;) ;) ;) ;)and it freezes to.

0

Share this post


Link to post
Share on other sites

Hmm... can you still disable Aero on Win8? If so that may stop it.

 

I thought Win8 had a compatibility mode to disable Areo, though.

 

Win8 doesn't use Aero, it uses Metro.  If you check out this MS doc, you'll find Win8 no longer supports less than 32-bit colour depth :

http://msdn.microsoft.com/en-us/library/windows/desktop/hh994464%28v=vs.85%29.aspx

 

Here is the relevant passage :

 

App fails due to using 8- or 16-bit color modes

 

As part of reimagining Windows 8 for Windows Store apps, one of the key changes is that the Desktop Window Manager (DWM) will now support only 32-bit colors in Windows 8. Lower color modes are now simulated.

 

Many older apps and games designed for Windows XP or before use 8-bit or 16-bit color modes. With no mitigations, these apps could fail to execute on Windows 8. However, when these apps enumerate or try to use any of the 8-bit or 16-bit color modes for display, PCA immediately identifies the issue and with the help of DWM, ensures that the app will work properly with the simulated color mode.

 

Note that this happens as soon as the app requests the low color modes and is transparent to the user. The user does not have to restart the app to get this mitigation because this fix is always needed to ensure that the app works properly.

 

 

Thanks,

DD.

 

0

Share this post


Link to post
Share on other sites

...so wait, they don't support it, and yet they do support it... whaaaat? That makes no sense whatsoever.

0

Share this post


Link to post
Share on other sites

I too made the leap to windows 8 from windows 7, before the game ran PERFECT in windows 7 using the CnCGraphicsPatch, but in windows 8 i found myself having the exact same issue as the OP. The menu was gone, but even worse ingame performance was horrible (even with the CNCGraphicsPatch).

 

Thanks to the suggestion of running GAME.exe in windowed mode (using -WIN) and using 16-bit color compatibility mode at the properties window i solved the missing menu issue!

 

The game still wasn't playable for me though. In windowed mode the game would randomly crash on me. I found out this happens because the window border crosses the edge of your desktop window. Always make sure the window is centered and set at a slightly lower resolution, my laptop runs at 1920x1080 so I set the game at 1900x1050 in SUN.ini

 

Then the game had alot of flickering graphics, plus it performed so bad that even with the CNCGraphicsPatch, especially when scrolling around the map the game was unplayable, I found out that you can fix this by forcing directdraw emulation, I used a wrapper for that and placed in my TS folder. http://bitpatch.com/ddwrapper.html

 

Now the game is perfectly playable, the only minor problem is that there’s a bit of flickering from the taskbar and near the edge of the screen at the metro/charms bar.

 

I hope this helps anyone!

 

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.