Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 1
carlitosway

CNCNet doesn't work on Mac Mojave

Question

I recently updated my MacBook to macOS Mojave, and after the update the CNCNet application simply doesn't work. I've been trying for days now, but to no avail. I even tried to uninstall and install the application again, but nothing works. Is this something that you are working on? I really want to play some good old Tiberian Sun :(

Also; are there anybody else with the same problem out there?

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

Any perspective on a solution? I'm using the porting kit but am having big mouse issues there -> it gets stuck in the corners, or just starts wandering on its own :(

 

A solution would be much appreciated :)

Share this post


Link to post
Share on other sites
  • 0
8 hours ago, Heraclitus said:

Any perspective on a solution? I'm using the porting kit but am having big mouse issues there -> it gets stuck in the corners, or just starts wandering on its own :(

 

A solution would be much appreciated :)

 

I'm currently working on updates for the mac issues, but I only know about the invisible mouse cursor and the random crashes (I think I got both fixed..), never heard about the problems you describe yet. Do you have a video of it? How often does this happen?

Share this post


Link to post
Share on other sites
  • 0

I had the problem that Heraclitus talks about when I updated to Mojave. I don't know much about computer stuff, but it seemed like the game resolution wasn't compatible with the Mojave update, when I played on 640x400 it was like the mouse didn't stop at the right and bottom sides so when touching these sides with the cursor the mouse would kind of get "stuck" to the sides and keep wandering. I tried a bunch of things, I found that it worked better with resolution 640x480, since it had black bars on the sides it was normal when moving cursor to right side. I didn't figure out how to completely fix it though so in the end I ended up just reverting to High Sierra which works perfectly like it used to.

Share this post


Link to post
Share on other sites
  • 0
On 4/7/2019 at 5:31 PM, McLovin said:

I had the problem that Heraclitus talks about when I updated to Mojave. I don't know much about computer stuff, but it seemed like the game resolution wasn't compatible with the Mojave update, when I played on 640x400 it was like the mouse didn't stop at the right and bottom sides so when touching these sides with the cursor the mouse would kind of get "stuck" to the sides and keep wandering. I tried a bunch of things, I found that it worked better with resolution 640x480, since it had black bars on the sides it was normal when moving cursor to right side. I didn't figure out how to completely fix it though so in the end I ended up just reverting to High Sierra which works perfectly like it used to.

 

Yeah, if the resolution isn't supported then it will stretch the game to a higher resolution so your game actually runs at 1280x800 instead of 640x400 but the trick to make this working is to lock the cursor into a rectangle with the size of the original resolution of 640x400. I guess the cursor can't be locked anymore on mojave...

640x400 is the only resolution that will always show up in the config program even if it's not supported (because it's the very original resolution of the game), your suggestion (using a different resolution) should workaround the problem since no cursor lock is required for all supported resolutions.

Note: The config program should list low resolutions first, they keep getting higher and at some point they're getting lower again, don't use the lower resolutions at the end of the list (Those are all scaled resolutions that require a cursor lock).

 

Share this post


Link to post
Share on other sites
  • 0

Thanks for your answers. I have sometimes a cursor lock in the corners, but more frequently a general malfunctioning of the cursor. The cursor then starts moving automatically. In these cases, when I click escape to abort the game, the cursor is also absent in the blue screen with the “resign” and “abort” and “option” buttons. I can only end the game then with the escape-alt-cmd key combination (Mac version of ctrl-alt-del). I tried very hard to get this wandering cursor issue on record, yet after tens of recordings I am pretty sure that for some strange reason recording actually prevents thid issue from occurring. It still does occur maybe 10-30% of the times I don’t record. I am not only a noob in RA but also in general with computers, so I have no idea what the explanation for this phenomenon could be. Yet I do have a solution now; record all games.

 

Still I hope the original cncnet app for Mac will start working again at some point, as I never had issues with that and recording all games is kind of annoying in terms of hard drive space and need for deleting etc.

Thanks for thinking along!

Share this post


Link to post
Share on other sites
  • 0
42 minutes ago, Heraclitus said:

Thanks for your answers. I have sometimes a cursor lock in the corners, but more frequently a general malfunctioning of the cursor. The cursor then starts moving automatically. In these cases, when I click escape to abort the game, the cursor is also absent in the blue screen with the “resign” and “abort” and “option” buttons. I can only end the game then with the escape-alt-cmd key combination (Mac version of ctrl-alt-del). I tried very hard to get this wandering cursor issue on record, yet after tens of recordings I am pretty sure that for some strange reason recording actually prevents thid issue from occurring. It still does occur maybe 10-30% of the times I don’t record. I am not only a noob in RA but also in general with computers, so I have no idea what the explanation for this phenomenon could be. Yet I do have a solution now; record all games.

 

Still I hope the original cncnet app for Mac will start working again at some point, as I never had issues with that and recording all games is kind of annoying in terms of hard drive space and need for deleting etc.

Thanks for thinking along!

 

I'm going to push the mac update now, it's supposed to fix the invisible cursor in-game, invisible cursor in the menus and random crashes. I assume the other cursor bug you mention could be related to the same problem too since you mentioned that you got the invisible cursor in the menus whenever it happens. 

Please post here if it should happen again after the update, I'll have a look into it.

 

About the cursor sticking to the corners, I actually thought it would always happen since you upgraded to mojave, I guess that's fixable too if it only happens sometimes. I will think about a solution for the problem and post here again with a command that lets you install a test build once I'm done.

 

The original cncnet app doesn't work for you? If you get a black screen with the cncnet app then maybe you just didn't see the popup that asked you for permissions. You will have to CMD+TAB back to the desktop and a there should be a popup asking for “Accessibility” permissions.

If there is no popup, there is also another way to add it manually, someone made a tutorial for it for another app, but you can follow their instructions and just add the CnCNet.app rather than the app they mentioned https://help.rescuetime.com/article/59-how-do-i-enable-accessibility-permissions-on-mac-osx

  • Thanks 1

Share this post


Link to post
Share on other sites
  • 0

For me the cursor sticking to corners/sides happened 100% of the time when I updated to Mojave, but it only happened when pushing cursor towards right/bottom sides or right side corners. (Maybe this is what he means with it not always happening). It felt kinda like the screen didn't fit with the game even if the game was on fullscreen so the cursor could move just slightly further out on these sides then where it was supposed to stop making it wander/sticking there. Could still move it back but it was harder then usually, like you had to pull a bit extra to get it off the side. But as I said, this now works like normal if revert to high Sierra.

The invisible cursor doesn't happen much anymore for me, but the random crashes happens quite frequently; that the game crashes and it shows a grey message on screen saying that the game crashed.

When can't move cursor in the blue meny in game I have found that the keyboard arrows still work so you can move with them and abort/resigne with enter key, but you can't see where you click so after pressing esc to get in the blue menu just gotta count how many times you need to press down on keyboard to get to abort then press enter.

Share this post


Link to post
Share on other sites
  • 0

I do have a different problem tho, its not affecting the game so doesn't really matter, but would be awesome if someone knew a quick way to fix it. I can't paste stuff in lobby or game room, like youtube links and stuff, when click paste nothing appears. Dunno if this is a Mac problem, but I suspect it is since the only other player who I have heard has the same problem also uses Mac. It does work in private messages tho. Any ideas about this?

Share this post


Link to post
Share on other sites
  • 0
On 4/15/2019 at 8:13 PM, McLovin said:

For me the cursor sticking to corners/sides happened 100% of the time when I updated to Mojave, but it only happened when pushing cursor towards right/bottom sides or right side corners. (Maybe this is what he means with it not always happening). It felt kinda like the screen didn't fit with the game even if the game was on fullscreen so the cursor could move just slightly further out on these sides then where it was supposed to stop making it wander/sticking there. Could still move it back but it was harder then usually, like you had to pull a bit extra to get it off the side. But as I said, this now works like normal if revert to high Sierra.

The invisible cursor doesn't happen much anymore for me, but the random crashes happens quite frequently; that the game crashes and it shows a grey message on screen saying that the game crashed.

When can't move cursor in the blue meny in game I have found that the keyboard arrows still work so you can move with them and abort/resigne with enter key, but you can't see where you click so after pressing esc to get in the blue menu just gotta count how many times you need to press down on keyboard to get to abort then press enter.

 

Oh I see... @Heraclitus can you confirm this?

 

19 hours ago, McLovin said:

I do have a different problem tho, its not affecting the game so doesn't really matter, but would be awesome if someone knew a quick way to fix it. I can't paste stuff in lobby or game room, like youtube links and stuff, when click paste nothing appears. Dunno if this is a Mac problem, but I suspect it is since the only other player who I have heard has the same problem also uses Mac. It does work in private messages tho. Any ideas about this?

 

I tried to reproduce this on linux, but didn't happen for me. I did some changes anyways, can you try these 2 commands and see if works then?

/install mclovin

/restart

Share this post


Link to post
Share on other sites
  • 0

 

On 4/15/2019 at 3:33 PM, FunkyFr3sh said:

The original cncnet app doesn't work for you? If you get a black screen with the cncnet app then maybe you just didn't see the popup that asked you for permissions. You will have to CMD+TAB back to the desktop and a there should be a popup asking for “Accessibility” permissions.

If there is no popup, there is also another way to add it manually, someone made a tutorial for it for another app, but you can follow their instructions and just add the CnCNet.app rather than the app they mentioned https://help.rescuetime.com/article/59-how-do-i-enable-accessibility-permissions-on-mac-osx

 

 

So I just tried your suggestions. I made sure the the CnCNet app is allowed to control my computer, but still it doesn't open. I made a screen recording so you can see. Each time I double click the CnCNet app the computer freezes for maybe 8 seconds. I have this problem since the Mojave upgrade. Thanks!

https://www.youtube.com/watch?v=deL4UQxgbM0&feature=youtu.be

Share this post


Link to post
Share on other sites
  • 0
12 hours ago, Heraclitus said:

 

 

 

So I just tried your suggestions. I made sure the the CnCNet app is allowed to control my computer, but still it doesn't open. I made a screen recording so you can see. Each time I double click the CnCNet app the computer freezes for maybe 8 seconds. I have this problem since the Mojave upgrade. Thanks!

https://www.youtube.com/watch?v=deL4UQxgbM0&feature=youtu.be

 

Video seems to be private, can't see it

 

10 hours ago, Heraclitus said:

@FunkyFr3sh I just had this out of control cursor issue again and made a little vid with my iphone. Again, it never happens when i do a screen recording. Shitty quality but I hope it works.

 

https://youtu.be/b0R7tNi4YWg

 

Can you try what McLovin suggested and use a different resolution? Try 640x480 instead of 640x400

Share this post


Link to post
Share on other sites
  • 0

 

On 5/1/2019 at 12:32 AM, FunkyFr3sh said:

Video seems to be private, can't see it

 

On 5/1/2019 at 12:32 AM, FunkyFr3sh said:

Can you try what McLovin suggested and use a different resolution? Try 640x480 instead of 640x400

I just changed resolution to 640x480 and had same issue. Made a better vid too. https://youtu.be/Km_oi8zZCr0

Share this post


Link to post
Share on other sites
  • 0
7 hours ago, Heraclitus said:

 

 

I just changed resolution to 640x480 and had same issue. Made a better vid too. https://youtu.be/Km_oi8zZCr0

Hm, that looks like it is still stretching the game. Make sure your display mode is set to "fullscreen" and not "Stretched" or "Borderless", these two would be causing the bug with any resolution too.

Share this post


Link to post
Share on other sites
  • 0
On 4/30/2019 at 11:23 AM, Heraclitus said:

So I just tried your suggestions. I made sure the the CnCNet app is allowed to control my computer, but still it doesn't open. I made a screen recording so you can see. Each time I double click the CnCNet app the computer freezes for maybe 8 seconds. I have this problem since the Mojave upgrade. Thanks!

https://www.youtube.com/watch?v=deL4UQxgbM0&feature=youtu.be

Did this ever get fixed? I have the same issue. Weird issue, first time it worked fine, played a game of multiplier but wouldn't let me start a new one, so I restarted the app but now I can't open it at all.

Is there any way to get around this and get the games up and running?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Techstorm
      Hey, so I want to recommend the classic C&Cs to some people I know, and they may be more likely to try it if it's free. However, while the first free C&C games were released as freeware, the primary sources of downloads are down, the only way is through 3rd party mirrors and the C&C Ultimate Collection includes them for a price. So are the first three games still considered freeware?
    • By Noahsark
      Hi,
      I was trying to fix a problem that cause my game frequently freeze after a few second of game starting. I searched many similar problems but there is nothing solve my problem. I tried almost every thing that I can find in the game folder.  My PC is win10+amd ryzen 5+ GTX1080ti. Finally I found the problem is the "VideoBackBuffer" option in redalert.ini. When I set VideoBackBuffer=No my game start to work properly. There should be something wrong when it is Yes by default. 
      This really troubled me many days since this option is not in any game config UI. Hopefully this will help the others that have same problem and this could be fixed soon. 
    • By Noyjitat
      Okay so for some very strange reason I have some trees and ore drills I'm unable to delete. When I first saved the map and loaded up they were not present until the game loaded but now they are. And the only way to ever supposedly delete them is to to put ton of stuff on them and then start deleting objects. Eventually I'm able to remove a few then some of the new ones I placed are also undeleteable. What is causing this? Is there another map editor I should be using other than final alert? I know final alert is pretty damn old like the existing games but people do make new and better tools over the years and im surprised nobody ever made something better or if they did I haven't found it.
    • By s.kums
      Hi all,
       
      In the original C&C Tiberian Sun you could configure a spy by adding the attribute Disguised=yes to the configuration section of a unit in rules.ini. The unit would then appear as an allied rifle soldier to enemies. It seems this attribute has no effect in the Cncnet version of Tiberian Sun, since my supposed spy is attacked by enemy units when they see him. Is there any way to get this feature back?
      Many thanks for any feedback!
       
    • By RustyBlowtorch
      I launch a game and it blacks out and nothing happens.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...