Jump to content
  • 0

Red Alert 2 - Entering Menu causes game to "Freeze"


Drewbsters

Question

Hi Everyone,

I just recently purchased the Command and Conquer Ultimate Edition fro Origin. Red Alert 2 and Yuri's Revenge both work correctly, single player and all.

I tried playing a quick skrimish in the cncnet client, and I noticed that whenever I try to enter the menu by hitting ESC or by clicking the menu button, the game appears to "freeze" but the music keeps playing. You cannot click on anything at this point and must force quit (ctrl+alt+del) everything and start it again. Everything works fine, if you AVOID the menu while playing a skirmish. If I launch the regular game, not using the cncnet client, I can run a skirmish and enter the menu no problem.

I did a quick search of the forum, and couldn't seem to find anything useful, aside from a topic that linked to an updated version of ddraw.dll. I tried that, and it didn't seem to make a difference.

I did update to the latest version according to the popup, but still have this issue.

Is this a known issue with a solution, or is it going to be a "it is what it is" kind of thing?

Thanks in advance!

  • Like 1
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Remove any ddraw.dll's you have in your game directory (One's that you copied in etc)

Try choosing a different renderer available in the client options. 
There's no need to copy files manually from places as the CnCNet client gives you these options in the client to stop you having to do that stuff.

The best available renderer options are in the client.

Experimenting with a renderer is simple, just open up the main CnCNet Yuri's Revenge client. Click Options > Display, and under the game renderers option select one and save. Then go to a skirmish game and see if it works best for you. 

Don't forget to try windowed mode too.

 

Link to comment
Share on other sites

  • 0

I have fresh install of yuris revenge from origin, and fresh install of cncnet for yuri.I have error with menus freezing game, and i cant select another render than "Default".Another selections gives me error "Cant write to ddraw.dll permission denied" or something like that, And yuris folder is write protected i cant create files inside, and paste files.What can i do with this problems?

EDIT2:I solved this problem by runing game without antivirus. Now im checking another antivirus software.I run GDI rendered and menus working properly.Previous antivirus blocked writing to dll files.

yuri.jpg

yuri2.jpg

Edited by Peter82kr
adding additional data
Link to comment
Share on other sites

×
×
  • Create New...