Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
FunkyFr3sh

How to install Red Alert 1 on Windows XP Vista 7 8 10 Linux MAC. 32 / 64bit

Recommended Posts

Ok i try withoit saving. Thx for the Advice.

In Mission 3 and 4 the same Problem?

Share this post


Link to post
Share on other sites

Probably the same problem in 3, but i didn't really check :) 4 is the last mission, you can save in that one withotu problems

Share this post


Link to post
Share on other sites

Did a couple of updates:

The installer will now check if one of the .iso files was already downloaded and won't download it again, that helps if you lose your connection during the installation. Just start the installer again and select the same folder as last time.

It does now check if the freeware .rar or .iso files were found in the same folder as the installer, in that case it will pick the right settings (Full CD-Install) automatically (No more need to browse to the folder of the files either)

I tried to theme the installer which is a pain in the ass with the tool i'm using (inno setup), here is the result:

installer.png

Share this post


Link to post
Share on other sites

Hi there,

i used your RA Installer and everything worked fine. I just played through the Addon Counterstirke und was starting the Ant Campaign. But always when i finish the second Mission --> "unable to read Scenario" and Crash. I loaded the Save game severel times and i also tried Mission restarts,. All with the same error. What can i do to Play the last 2 Ant Missions ;)?

 

Thanks

Drak

 

I just tried it, works fine if you are not loading any savegames. But once you load a savegame you will end up with that error.

 

You can try to play it through without saving or you wait until the bug is fixed :D

 

I thought that the Ant Saved game bugs was fixed?

Share this post


Link to post
Share on other sites

Is this the same problem as in C&C1? In TD it messed up the campaign ID in savegames by saving the player ID instead, which worked fine for GDI and Nod, but which resulted in the dino missions using the Multi4 player ID (7) as campaign ID, while they should've used "2".

 

Not that it still matters for C&C1 now I moved those missions to the New Missions menu :P

Share this post


Link to post
Share on other sites

I believe the problem in C&C1 was solved by first starting a new dinosaurs campaign, and THEN loading your savegame inside that. Maybe that fixes it for RA too?

Share this post


Link to post
Share on other sites

Seems like the same thing, then. The campaign ID was what caused the CD check, in C&C1.

 

Odd that Drak has trouble with that, then.

 

Drak, did you install any additional patches or something on your RA?

Share this post


Link to post
Share on other sites

Oh yeah, gary1910, do you perchance have the scu44ea.ini file from Nyurguds' TFD fixes Page in your Red Alert Directory which you pointed to in the installer?

 

If so, that fix is outdated and is not overridden by the installer which has the most recent version. Just delete it manually, see if that works.

Thanks for the reply as I was waiting for the solution. 

 

Anyway I have searched for this scu44ea.ini file in my computer and it can't be found.

 

In fact, I don't think I have installed it, so I don't think this is source of the crash.

 

Tks anyway.

Share this post


Link to post
Share on other sites

Hi there,

i used your RA Installer and everything worked fine. I just played through the Addon Counterstirke und was starting the Ant Campaign. But always when i finish the second Mission --> "unable to read Scenario" and Crash. I loaded the Save game severel times and i also tried Mission restarts,. All with the same error. What can i do to Play the last 2 Ant Missions ;)?

 

Thanks

Drak

 

Fixed the problem and updated the installer

 

Oh yeah, gary1910, do you perchance have the scu44ea.ini file from Nyurguds' TFD fixes Page in your Red Alert Directory which you pointed to in the installer?

 

If so, that fix is outdated and is not overridden by the installer which has the most recent version. Just delete it manually, see if that works.

Thanks for the reply as I was waiting for the solution. 

 

Anyway I have searched for this scu44ea.ini file in my computer and it can't be found.

 

In fact, I don't think I have installed it, so I don't think this is source of the crash.

 

Tks anyway.

 

I cannot reproduce that crash, can you create a savegame right before the crash happens and upload it here?

Share this post


Link to post
Share on other sites

 

I cannot reproduce that crash, can you create a savegame right before the crash happens and upload it here?

 

OK, I try to attach the file but the forum don't allow it, so I rename to a txt file, you need to rename it back to a save game.

 

BTW, when I click on the Chrono tank, the game crashed.

SAVEGAME.txt

Share this post


Link to post
Share on other sites

I cannot load this savegame, what kind of red alert installation do you use? Tell me the version number that is written in the main menu

Share this post


Link to post
Share on other sites

I cannot load this savegame, what kind of red alert installation do you use? Tell me the version number that is written in the main menu

 

My version is V303P-1BETA1V1

Share this post


Link to post
Share on other sites

ok good, maybe your resolution is different than mine :) Can you upload your redalert.ini too?

Share this post


Link to post
Share on other sites

I'm 99% sure that V303P-1BETA1V1 has the Ant Mission saved game bug.... I would go over to http://iran.cnc-comm.com/ra/# and download the Main MINIMUM game package. Take the RA95.exe from it and put it into your install. You will have to replay the mission as the bug will be in the saved game it self but once you play it with the new .exe you should be fine.

Share this post


Link to post
Share on other sites

I think I know the problem, I did install aftermath.ini file from here:

 

http://ra.afraid.org/html/ra/aftermath.html#moreunit

 

so to enable Helicarrier and the Phase Transport for MP/skirmish play.

 

I revert it to the one from your installer and does not seem to crash any more after the Chrono Tanks appear.

 

I think the one from "Red Alert Archive" is not anymore compatible with this latest version of RA.

 

Sorry about all the trouble I caused.  :(

 

Anyway you could d/l it & analyse it and perhaps come out with a compatible version.

 

Additional info:

I just tested it with "more unit aftermath.ini" on a skirmish play, after the Chrono tank was built it, it crash when I selected it.

 

With the original aftermath.ini, it did not crash.

 

 

Share this post


Link to post
Share on other sites

I'm 99% sure that V303P-1BETA1V1 has the Ant Mission saved game bug.... I would go over to http://iran.cnc-comm.com/ra/# and download the Main MINIMUM game package. Take the RA95.exe from it and put it into your install. You will have to replay the mission as the bug will be in the saved game it self but once you play it with the new .exe you should be fine.

 

I fixed it already, V303P-1BETA1V1 got no more save game bug

 

I think I know the problem, I did install aftermath.ini file from here:

 

http://ra.afraid.org/html/ra/aftermath.html#moreunit

 

so to enable Helicarrier and the Phase Transport for MP/skirmish play.

 

I revert it to the one from your installer and does not seem to crash any more after the Chrono Tanks appear.

 

I think the one from "Red Alert Archive" is not anymore compatible with this latest version of RA.

 

Sorry about all the trouble I caused.  :(

 

Anyway you could d/l it & analyse it and perhaps come out with a compatible version.

 

Additional info:

I just tested it with "more unit aftermath.ini" on a skirmish play, after the Chrono tank was built it, it crash when I selected it.

 

With the original aftermath.ini, it did not crash.

 

np, I attached my version of aftrmath.ini

 

aftrmath.ini

Share this post


Link to post
Share on other sites

 

np, I attached my version of aftrmath.ini

 

I tried  your aftrmath.ini which enable additional units for MP and work perfectly without Chrono Tank crash. Tks  :D

 

BTW did you put your version of "more units aftrmath.ini"  for d/l in the Download Section?

Share this post


Link to post
Share on other sites

Everytime i try t use the installer on Windows 10 it says HTTP Error 403  cant connect to server x(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...