Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0



HI, I am facing lag during the game, it starts slow at beginning than it gets better, I have contacted my ISP, and confirmed that there is no issue with my connection speed, and they said it is with the server, I have 50mbps internet, everything else I use, ex. youtube or any other games, it runs perfectly and no lag / no buffer.

The only issue is when I only play RA, wondering if someone can help me solve this issue, or if someone faced similar case.




Share this post

Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

Photon seems to have the same problem, was in a game with him a few days ago and it was slow at the starts just like all your games.

He was about to ask his ISP, maybe figured something out, you should ask him. I will ask him later too when I see him

  • Upvote 1

Share this post

Link to post
Share on other sites
  • 0

Hi Funky, sure will ask him, we were chatting me and him last night about our issues, I have contacted my provider, but they said its about the server, not sure what that means, my ping is always 5ms. but the lag is there.

Share this post

Link to post
Share on other sites
  • 0

Hi ,


me and Photon, found out, that when we play with each others, we have no lag, but excellent speed, because we play locally, we are in the same area, but when we connect with other players (internationally ) it lags, so it about the server, wonder what can be done

Share this post

Link to post
Share on other sites
  • 0

There is no server used, it's Peer-to-Peer (that means direct connection between players without any server in between). But I already tested that with you when I told you to type in the commands, one of the commands disabled Peer-to-Peer and was sending all your data through a server rather than directly to the players (That didn't work either).

I guess you may have a similar problem as the chinese players, they have bad routes to certain locations which is causing lag (packet loss). But they also have another problem, the internet censorship (the great firewall of china) on top of that.

They're using VPN's to get around the problem, but that is causing lag too

Share this post

Link to post
Share on other sites
  • 0
10 hours ago, Suckernoob said:

Hey, I'm facing the same thing..

You are also from the U A E? Cause everyone with this problem comes from there. What game you play?

Share this post

Link to post
Share on other sites
  • 0
On 4/27/2017 at 10:45 PM, FunkyFr3sh said:

You are also from the U A E? Cause everyone with this problem comes from there. What game you play?


I live in UAE yeah... Any fix? I have another thread for my problem.


Oh I play Yuri's Revenge.

Edited by Suckernoob
Forgot to mention what game I play.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By jesterrescue1
      I was trying to be careful and the map worked in its early versions. The version have now is causing myself and other players to desync about 5 minutes into the game with this custom map. The map is kinda fun and different. Tried to take inspiration from starcrafts style. Its not too radical. But
      I think my questions are what makes the red alert 1 (include aftermath) dsync online? Consider its custom map, unit alterations, image changes. Worse case scenario I'll release it as a single player skirmish map. I make use of the spawn file that holds images of c&c dawn units. The RAedit adds triggers. I tried deactivating the triggers and teams hopping that was the mighty fix. Well didn't seem to do it. 
    • By FunkyFr3sh
      We removed the macOS downloads since Apple dropped support for 32-bit applications in their latest version of macOS (10.15 Catalina).
      Downloads might be added again at a later point once there is a solution for supporting the new macOS Catalina.
      If you're running a older version of macOS you can still try to install the games (C&C / Red Alert / Tiberian Sun) manually:
      Step 1: Install wine-stable https://wiki.winehq.org/MacOS
      Step 2: Download the following script, right-click and select Open https://downloads.cncnet.org/cncnet.command.zip
      If you're running the new macOS Catalina 10.15:
      Use bootcamp: https://support.apple.com/en-us/HT201468
    • By SOL1981
      On a Mac running VMWare Fusion with Windows 10. 
      Game runs run, but whenever I go to "Play Online" CnCnet loads fine, I select online, and the chat window loads but never connects / no one is ever on it.
      Is this some network setting I need to change (I'm an Apple guy haven't used PC's in close to 20 years). Or is there another plugin or patch to install.
      Again the game runs fine and this loads, just can't seem to "connect" into the network.
      My father is running this same game on a Mac through the Wine Emulator and connects and plays online all the time.
      I had the same thing working but just upgraded to Mac Catalina today and it wiped out the game.
      Thanks for your help!

    • By FunkyFr3sh
      Tiberian Sun Single-Player Campaign is now available on macOS and every Linux download.
      Red Alert Single-Player Campaign / Multiplayer downloads were merged together with Tiberian Sun into one download. 
      Downloads are now also available for Pacman-based Linux distributions (Antergos, Manjaro Linux, ...).
      Ubuntu, Linux Mint, ...                                  cncnet_1.0_all.deb
      Fedora, openSUSE, ...                                  cncnet-1.0-2.noarch.rpm
      Manjaro, Antergos, ...                                  cncnet-1.0-1-any.pkg.tar.xz
      macOS                                                           CnCNet.dmg
      Find all downloads here                            https://cncnet.org/download
      You may also be interested in the following snaps made by user [email protected] 
      Red Alert (Full Game)                               https://snapcraft.io/cncra
      Tiberian Sun (Full Game)                         https://snapcraft.io/cnctsun
    • By Siberian GRemlin
      In C&C: Red Alert vehicle named as "V2 Rocket" is a 9K52 "Luna-M" or "FROG-7" in NATO reported name.
      I suggest to improve the vehicle name or make it optional.
      Ingame vehicle model.

      "Luna-M" (FROG-7) – Soviet short-range artillery rocket system.

      V-2 – Nazi Germany long-range guided ballistic missile.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Create New...