Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
VonIthipathachai

Red Alert keeps crashing when I load save files (Windows 10)

Question

Hello, there.  I'm trying to play Red Alert 1 as part of the Ultimate Collection, but the game keeps crashing on me, particularly whenever I reload a save file.  I've already patched the game with FunkyFr3sh's installer and followed the advice given here:

So far, it's still not working and I have no idea what to do.  I have a crash dump.  Where do I need to upload it?

Edited by VonIthipathachai

Share this post


Link to post
Share on other sites

8 answers to this question

Recommended Posts

  • 0

So it only crashes with that one specific savegame? You can attach the file here on your next post

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, FunkyFr3sh said:

So it only crashes with that one specific savegame? You can attach the file here on your next post

I have not attempted to play anything outside of the Allied campaign yet.  I'm currently on Allied Mission 3, which is where I've had to do the most save reloading so far because shooting down Attack Dogs before they can one-shot Tanya is a pain.  Missions 1 and 2 were easy enough not to need any save reloading, so I didn't experience any problems in those.

Here's my crash dump: https://drive.google.com/open?id=1CrHGGaSGuqZoYTVzINf3x90_PHeQ_vZ8

I have to give it as a Google Drive link because it isn't one of the accepted file types for direct upload.  Let me know if you need any other information.

Share this post


Link to post
Share on other sites
  • 0

Update.  Skirmishes work completely fine.  Crashes only seem to happen after loading previously saved files.

EDIT: Also got this message in addition to the one telling me to send a crash dump to Iran for debugging.

 

Capture.PNG

Edited by VonIthipathachai

Share this post


Link to post
Share on other sites
  • 0

Can you upload the savegame?

 

Is "singlecpu" set to "true" inside of ddraw.ini in your game folder?

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, FunkyFr3sh said:

Can you upload the savegame?

 

Is "singlecpu" set to "true" inside of ddraw.ini in your game folder?

singlecpu is indeed set to "true".

Where would I find these savegames in my game folder?

Share this post


Link to post
Share on other sites
  • 0

@FunkyFr3sh I think these are my savegames?

https://drive.google.com/open?id=1Lfy6eYhGUgu8qBPNxPjwgl0nrv4P74TC

From what I can tell, the game itself plays perfectly fine.  The first time I load a save file after booting the game up, everything works like it should.  The second time I load a save file after booting the game up is usually when crashes occur.

Share this post


Link to post
Share on other sites
  • 0

Until this crashing issue gets sorted out I've found a crude workaround.  I can "reload" a save file without the game crashing by aborting the mission, exiting the game completely, starting the game back up, and loading the save file again from the main menu.  It's hardly ideal, but it'll have to do for now, as I'd rather not have to skip Red Alert and play Tiberian Sun instead just because of some technical difficulties.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By AndrewFord
      on the CncNet5 (RA, TS, TD version) there is usually a flashing green button that says "streaming" whenever someone is live on twitch but it doesn't show anymore. When shall this be fixed.
    • By Genio
      I want to edit the vehicle and building graphics. Where do I find the original graphics and where do I have to place the edited ones in cnc to replace the original?
       
      Greetings and thank you
    • By sk0rp
      I was just wondering but is this an issue that is on the team's radar?
       
      If you take my name Bane_ for example on this month's RA ladder, there is a total mix of average fps for my games (as low as 43 fps even...). By way of comparison, if I'm playing normally on CnCNet I can quite happily be in 8 player games with it running at full speed without any issues at all. Multiple other people suffer from the same issue if you go checking through the names so I'm not sure what's up really.
       
      It isn't lag but when a game decides it's going to average more around say 40-50 fps, you experience it as a periodic hitching all the way through the match (right from the word go so it doesn't worsen as more and more units and structures are built) and it leads to a pretty unpleasant game as it messes around with your build timings and Q and so on in what should be a fast-paced game.
       
      Is there any obvious culprit that could be causing dropped frames like that? Restarts don't seem to help, neither does running the quickmatch client directly with CnCNet closed and as few other programs open as possible.
    • By NHG(N_HuyGamingVN)
      Can someone find music.ini for RA1 to me
      I try to add some music but i didn't find any ini files yet.....
       
      THANK YOU,
      NHGVN
    • By ConstructionWorker
      I've been wanting to play red alert for a while but i don't know which version to download. I am currently using macOS Catalina 
       
      If someone can help me I would appreciate it.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...