Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0

Red Alert 2 Game Speed, fixes don't work?


Doblofino667
 Share

Question

Hi all

I hope there is someone who can help me get out of this one. 

I'm trying to run Red Alert 2 (original CD version) on Windows 10 and the game runs way too fast!

Here is where I am:

- I've installed the 1.006 patch

- I've tried the " - speedcontrol" fix in a hundred different ways. No joy

- I've tried changing the config file by running as an admin and saving changes to the game speed. I've taken it down even to 1 and no joy

- I've lastly tried a hex editor (I use HxD) to change the numbers that I see everyone citing. Something about changing a 47 to a 70, but mine says 58. 

Hence, it's a no-go for me. Is there anything else I can try? I think my best bet is the Hex editor, but since nobody can give me definitive guidance on that, I am as stuck as a horse in a hole. 

Please help!

J

Link to comment
Share on other sites

8 answers to this question

Recommended Posts

  • 0
On 3/15/2020 at 9:23 PM, FunkyFr3sh said:

How did you even get the CD version to work on windows 10 (it isn't supported...)? Did you download any patches or ddraw wrappers or did you install cncnet?

Hey man thanks for responding. 

This is weird. The laptop I am playing it on used to be Windows 7, I think (I did upgrade it to 10) And yes, RA2 absolutely does not work on my desktop. I assumed that is due to hard

The only stuff I can remember doing was downloading the V 1.006 patch and another patch to stop the game from freezing every 30 seconds. 

It runs fine, but too fast!

 

Link to comment
Share on other sites

  • 0
41 minutes ago, phillgl said:

Hi Doblo,

Im having the same problems.

Was having display issues playing so downloaded the latest patch.

Now I cant slow it down. The game speed option isnt in setting anymore.

Am stuggling for ideas to fix ths.

Thanks

 

What patch did you download and where?

Link to comment
Share on other sites

  • 0

I just installed latest cncnet. it was the 1st time ive installed it as i read it would solve my display issues. which it did. Ra2 runs a lot better once cncnet was installed, but just in game is wayt to fast. I tend to play offline atm as I havent played ra2 for probably 15 years. I purchased and downloaded from origin.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By GMANtheGr8
      Hi,

      Anybody can help me? I'm getting this error message: 

      And after that I get this:

       
    • By Malcolm25
      looking Just for some people to be able to play a "traditional" game of C&C Tiberian Dawn or Red attentive.thx
    • By CnCRedAlertFan
      Can't host a game of Yuri's Revenge in CnC Net, only i load and I get a Victorious screen.
       
       

    • By CnCRedAlertFan
      First time I was able to load into the game but the update failed, I got an error in the update and said something about firewall not allowing clientdx.exe to update. My firewall and anti-virus arent the issue and i read others are also having this problem.
      Now I can't even launch the game due to a crash
       
      Update: fixed by reinstalling
    • By Archangel777
      C&C yuri's revenge campaign cuz i prefer just playing the campaign on repeat lol. So basically everything works great except for right past the loading screen when u really get into a game and it tweaks out by freezing the screen. if i tab out and back in its fine until i finish the misson. when it tries to leave the mission to go to the post campaign mission screen it freezes up for good and i couldnt do anything to fix it. and i will say this im kinda an idiot when it comes to the computer stuff but i can do enough to get the game started thanks to tutorials. my question is does any one know how to fix this? the it freezes like this anytime it starts or ends a mission.

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...