Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Anarasha

Red Alert 2 Ultimate Collection - Menu relocation and mislabel

Question

Hello. So sorry to just join for bug support. Let me start out by saying that it warms my heart to see such a huge community gathered around arguably my favourite childhood games. But now, to not stray off topic too much, here's the issue.

System information:

  • Red Alert 2 from the Ultimate Collection
  • Windows 10 Home, 64 bit
  • Intenso SATA III SSD drive
  • 4095 NVIDIA GeForce GTX 970 graphics card
  • Intel Core i5 4460 3.20 GHz
  • 16gb DDR3 Dual-Channel 799 MHz
  • ASRock B85 Pro4 mainboard

I started out by installing Red Alert 2. I fixed some of the standard issues that comes with it and got it running. But due to the Alt-Tab issue, I went and installed a DDraw file. As that didn't work and nothing else I could find worked, I came across CNCNet. And as promised, installing the client fixed a whole lot of annoying issues in Red Alert 2. However, my menus got messed up a LOT. My start menu works really well, perfectly in fact. Start campaign, start Skirmish and everything. But the options menu is royally messed up. And when I get in game, the pause menu is messed up. Several of the visible buttons have the wrong label and only shows the correct one once clicked. Furthermore, Load Game is missing, Restart is missing from Abort and the sliders are misaligned in the game options menu.

Thinking I did something wrong, I tried completely uninstalling RA2, deleted all the files in the folder and the folder itself, did a fresh Origin install and tried to boot it fresh. The problem which I didn't have before persists now, even with a clean Origin install. With or without the amazing fixes from CNCNet, my RA2 is almost unplayable due to specifically the missing load game button and restart mission button. The game itself runs well, but as I am currently playing missions for nostalgia, I cannot actually be without those two buttons.

So far I tried a LOT. I tried installing different DDraws, both manually and through the CNCNet client, to no avail. No setting changes I tried fixed it. I tried several of the graphic tricks out there, several compatibility modes(and none), disabling high res DPI scaling and screaming at the heavens.

I am completely and utterly out of ideas, and I hope a kind soul in here will have the answer I seek. I couldn't find it via the Search menu, but honest talk, I didn't quite know what to search for, so if this is a common and often answered issue, I am very terribly sorry.

I attached screenshots showing that the main menu and start game menu works, and then I hope you can get a sense of the weird collage of broken menu items I also attached. I wanted to save space to not upload 7 pictures

RA2Brokenpart.jpg

RA2workingpart.jpg

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

if you select the renderer cnc-ddraw (d3d9) on cncnet then most of these problems should be gone. The sliders are still misaligned but that's not a big problem though, just looks a bit weird.

 

The problem is caused by high dpi settings that you've enabled in windows, you could set it back to the original 100% to solve the problem completely

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, FunkyFr3sh said:

if you select the renderer cnc-ddraw (d3d9) on cncnet then most of these problems should be gone. The sliders are still misaligned but that's not a big problem though, just looks a bit weird.

 

The problem is caused by high dpi settings that you've enabled in windows, you could set it back to the original 100% to solve the problem completely

Update: I have no idea what did it, but I think my theory was right, something in a registry had changed. I did a system rollback to just before my earliest install of Red Alert 2, and now the clean install has perfect menus again - at least now I have somewhere to start :D

Thank you so incredibly much for your time, I don't think I'd have figured this out without your help.

 

Thank you so much for taking the time to respond, I really appreciate it.

That was actually among the list of things I'd tried, but I just tried again. My scaling is set to 100% for both my monitors, and I just tried to run it with the cnc-ddraw renderer. Unfortunately this had no impact on the issue 😕

Just so we don't talk past each other - have I understood it correctly when I say that DPI scaling is the Windows setting named "Scale and layout" that scales both text and icons without changing the resolution?

 

If so, is it possible that one of the early fixes I tried for the alt-tab issue edited a registry file and somehow overrides the Windows DPI scaling for Red Alert 2?

Edited by Anarasha

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Scallywag
      Hey everyone. I am new here...I have DL the client and I am able to play online or skirmishes just fine. my issue is I can not play the missions (the game keeps crashing)  when i use the old RA2/Yuri path. The C&C.net path does not give the option for the missions. is there a repair patch that will allow me to play the missions?  All my C&C games come from Origin if this matters. thanks Scally.. 
    • By asfd2315
      I played against this guy and he generated a reconnection error twice:
      https://ladder.cncnet.org/ladder/1-2021/yr/games/258082
      https://ladder.cncnet.org/ladder/1-2021/yr/games/258088
      This player obviously cheats. I've never had a reconnection error on cncnet before.
      I hope you can ban this guy.
      SYNC_CNCNET0.TXT SYNC_CNCNET1.TXT
    • By Yesenia
      I have been trying to play RA2 with my boyfriend. We are able to get the game started but as soon as we start building the game freezes and eventually kicks the other person out. We can start individual games and run them at the same time but as soon as we start a game together it crashes. we are playing in the same house, same internet, could our IP address be throwing the gam e off? Here is the error log. client.log
    • By TwinkyBong
      I love this launcher since I can play online with friends in a windowed 1280-800 resolution.
      But I have a question, I need to touch something to play the SINGLEPLAYER game (since I wanna stream the campaing) in a windowed 1280-800 resolution?
      If yes: How?
      If not: Well, I dont lost anything asking
    • By Serbian
      I have downloaded and installed the CNCnet5_YR_installer and it opens and works but it wants to update to v7.7 and if i update it to v7.7 it doesn't work. it opens a clientdx.exe process but doesn't open, not even a black screen, I have updated .NET framework to 4.5. I Have tried launching it with my firewall off and the same thing happens
      I run Windows 7 ultimate x64 on an i3.
      Help would be greatly appreciated so I can Command & Conquer
       
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...