Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0

Question

So I managed to get my Red Alert 2 and Yuri's Revenge game working fine on my PC with little issue, in the main menu at least. But when I load a game up and open up the in game menu (keep in mind that everything is running as it should, even moving units around), some buttons will not show up and be overlapping. I see Save Game and Delete Game, but when I click on Save Game, It takes me to the Options Menu, and when I click on Delete Game, it takes me to the Abort Game menu. The Resume Game button works just fine. I have done all of the compatibility checks that I needed to do to make the game run and still this problem shows up, even on my Mental Omega mod.

My system is running Windows 7 with a Ryzen 5 1500 and a Radeon RX 550 Series with dual DDR4 16 GBytes running at 1197.1 MHz.

Any help would be appreciated.

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Hello,

If you are experiencing slow or choppy gameplay whilst playing on CnCNet, there are a few steps you can take to troubleshoot the problem.

  1. Install the CnCNet client 
  2. This will look for your existing game directory.
  3. Once installed run CnCNetYRLauncher.exe or the shortcut supplied.
  4. Click "Options"
  5. Select "Display" and under the render options, select a new renderer. Commonly, TS-DDRAW works best.
  6. Click Save, and launch Skirmish. 
  7. Play a game with the AI. If the gameplay is fast then this renderer will likely be the best for you.
  8. If it hasn't worked, repeat from step 5 until you find a renderer that works best with your system.

Failing the above, ensure your video drivers are up-to-date. You are running a suitable resolution the game can handle.

render.png

Share this post


Link to post
Share on other sites
  • 0

Have you tried using the other renderers in the list and trying those? 

Share this post


Link to post
Share on other sites
  • 0
On 6/17/2018 at 11:20 AM, Nalothisal said:

So I managed to get my Red Alert 2 and Yuri's Revenge game working fine on my PC with little issue, in the main menu at least. But when I load a game up and open up the in game menu (keep in mind that everything is running as it should, even moving units around), some buttons will not show up and be overlapping. I see Save Game and Delete Game, but when I click on Save Game, It takes me to the Options Menu, and when I click on Delete Game, it takes me to the Abort Game menu. The Resume Game button works just fine. I have done all of the compatibility checks that I needed to do to make the game run and still this problem shows up, even on my Mental Omega mod.

My system is running Windows 7 with a Ryzen 5 1500 and a Radeon RX 550 Series with dual DDR4 16 GBytes running at 1197.1 MHz.

Any help would be appreciated.

This problem might appear on Win 7 by wrong DPI screen setting. Try set your screen scale to 100%.

How to do:

https://technet.microsoft.com/en-us/library/ff629368.aspx

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
14 hours ago, Grant said:

Have you tried using the other renderers in the list and trying those? 

DDWrapper causes a freeze when I go to the escape menu, everything else has the same issue persist. I even went to the lowest resolution setting and the problem still persists.

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

I have the same issue on Win7, DPI is at normal 100%.

Happens in vanilla game, and cncnet modded game.

Some buttons are overlapping/on top of other buttons.

Resolutions also have no effect on buttons. Renderers have no effect too.

This happens in vanilla and TFD and cncnet skirmish, and cncnet modded singleplayer...

And I can't get Game Speed slider in Campaigns...

Edited by 2mg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Phantom007
      After the latest patch, I can join games; however, when the game begins to load I load by myself. As does whomever I am with and the game immediately goes to (VICTORIOUS) No one is ever synced up and loading at the same time. Not only do I have this problem joining other games, I created my own and no one syncs up- loads at the same time. I have changed servers etc. Finally I have a friend I always play with, he has the same issues/ never syncs with others. Even when he has created his own games. We have not been able to play for days as every time it loads- no one loads together and the game immediately shows victorious and puts players back into the game lobby. 
    • By bthncgdr1
      https://cdn.discordapp.com/attachments/739246335882035260/739267544107581491/unknown.png what is the solution to it?
    • By PandaDent
      Hi,
         I just downloaded the latest update 7.5 and it caused my display screen to shrink into a small box on the upper right corner.  How do I increase the size to fit my monitor?
       
      Thanks for your help.
       
    • By netflixYR
      Player name "11" doing re connection error every game against yuri
       
    • By Bisteee
      I am playing with my friends and this is the outcome it happens about 10-15 mins of the game.
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...