Jump to content
FunkyFr3sh

Tiberian Sun patches - Fix for the windows 8 / 10 menu problems and more

Recommended Posts

On 6/7/2017 at 0:06 AM, Worthiestnobody said:

alright so when i enable default theres a black screen and i dont see anything, when i enable TS-DDraw the menus load fast but still the game crashes at the dialague loading screen after saying (Creating theories on likely enemy plan...), samething when IE-DDraw is enabled and the samething but with screen flickers with the setting everyone starts out with.

 

I guess you'll have to wait a bit, hopefully we can figure these issues out soon.

 

 

-

TSpatch updated to 2.0

Fix for the too fast scrollrate issue

Fix for the movie scaling bug where parts of the movie were not visibile

Share this post


Link to post
Share on other sites

I believe this question was asked already, but still: why have 2 incompatible clients with different feature set? I do actually prefer this one since it keeps true to the original, but isn't it possible to at least have features implemented in one also be in the other? this one has better performance for me and finally have a sane scrolling speed, but lacks things like mouse-hower health bar or fix for harvester animations color

Share this post


Link to post
Share on other sites
Posted (edited)

hello i just downloaded this version of tib sun i was super excited to get back into it but it crashes after about 5 min of playing a mission it just start to hang and drop frames and then hard locks my computer it seems to be the problems the graphics patch is indented to address but im still suffering it is the graphics patch included in the download?

 

Edited by sunstar

Share this post


Link to post
Share on other sites
On 6/12/2017 at 3:19 PM, Milkey Wilkey said:

I believe this question was asked already, but still: why have 2 incompatible clients with different feature set? I do actually prefer this one since it keeps true to the original, but isn't it possible to at least have features implemented in one also be in the other? this one has better performance for me and finally have a sane scrolling speed, but lacks things like mouse-hower health bar or fix for harvester animations color

This patch is mainly for those who already have the game (e.g. The ultimate collection from origin). mouse-hower health bar and fix for harvester animations color will probably be added soon (waiting for dkeeton to release his new patch). Any kind of forced gameplay changes will never be included though (This is not meant to be a mod)

 

1 hour ago, Bravo1220 said:

Thankyou for this awesome patch!

no problem! :D

 

1 hour ago, sunstar said:

hello i just downloaded this version of tib sun i was super excited to get back into it but it crashes after about 5 min of playing a mission it just start to hang and drop frames and then hard locks my computer it seems to be the problems the graphics patch is indented to address but im still suffering it is the graphics patch included in the download?

 

What kind of TS install do you have? What are your rendering settings in the TS-Config? Try to play around with the setting a bit, some might work better for you.

Share this post


Link to post
Share on other sites
Posted (edited)

I am using the download from this site i then clicked single player and am using the client it downloaded none of the graphics setting fix problem, or the game wont start at all with them selected. the setting that works best (will work for about 5 minutes until there are too many units and objects on screen then my computer will either reboot or just hard lock) is dxwnd with emulation set to primary buffer and none of the options ticked i have the graphics patch enabled  and the game is set to single processor affinity lowering the resolution seems to help but it will still eventually crash (ideally i would play on 1920x1080).

i am trying to run it on an msi gl62 6qf laptop here are the specs if it helps: https://www.msi.com/Laptop/GL62-6Qf.html#hero-specification

Edited by sunstar

Share this post


Link to post
Share on other sites
10 hours ago, sunstar said:

I am using the download from this site i then clicked single player and am using the client it downloaded none of the graphics setting fix problem, or the game wont start at all with them selected. the setting that works best (will work for about 5 minutes until there are too many units and objects on screen then my computer will either reboot or just hard lock) is dxwnd with emulation set to primary buffer and none of the options ticked i have the graphics patch enabled  and the game is set to single processor affinity lowering the resolution seems to help but it will still eventually crash (ideally i would play on 1920x1080).

i am trying to run it on an msi gl62 6qf laptop here are the specs if it helps: https://www.msi.com/Laptop/GL62-6Qf.html#hero-specification

 

Oh DxWnd it is, yes that's a known problem. Some player get this issue and other not. It's weird that all other options are not working.

You can try to use the DxWnd Windowed mode, from what I heard it doesn't cause such issues on problematic machines. If you don't want to play in a window then you could set up a fake full screen by enabling DxWnd  + "Windowed mode"  + "No Window Border" + game resolution 1920x1080

 

Fake fullscreen should be working fine for the campaign. For Skirmish/LAN/Online use the CnCNet client instead

Share this post


Link to post
Share on other sites

thanks! that has it mostly working frame rate still isnt good but its playable!

Share this post


Link to post
Share on other sites
Posted (edited)

Hey, first of all thanks for the patch. I'm having a problem running this smoothly with windows 10, it's the desktop flickering through into the game now and then, you have a solution on the main page but it confuses me, I don't know how to ''run the config page'' and change ''ddwrapper to default'' can you explain how? Thanks.

Edit: Nevermind, fixed. I'm stupid. It was all there in the settings as you launch the game program.

Edited by BretN7

Share this post


Link to post
Share on other sites

Hi, thx for your patch. 2 questions:

 

Where can i download full offline installer? Which won't require internet? 

Why it takes ages to travel through menus. I click on options and they will open in 5 seconds...

 

Windows 10, nv 1070 latest driver.

Share this post


Link to post
Share on other sites
2 hours ago, vorob said:

Hi, thx for your patch. 2 questions:

 

Where can i download full offline installer? Which won't require internet? 

Why it takes ages to travel through menus. I click on options and they will open in 5 seconds...

 

Windows 10, nv 1070 latest driver.


I think you are not talking about TSpatch but about the full game single player installer? If that's the case then I'll have to forward your question to the guy who made the single player installer (I only take care of TSpatch myself)

 

Share this post


Link to post
Share on other sites
On 12.06.2017 at 2:51 AM, FunkyFr3sh said:

 

I guess you'll have to wait a bit, hopefully we can figure these issues out soon.

 

 

The same problem here. Game will load but it takes like 3-4 minutes. After it works fine, loads fine. Only first loading takes so many time.

 

Yesterday i found another problem - i was reloading mission and game freezes. There is no problem if You loose mission and choose to play again...only when loading without mission defeet.

Share this post


Link to post
Share on other sites
5 hours ago, kraven2000 said:

 

The same problem here. Game will load but it takes like 3-4 minutes. After it works fine, loads fine. Only first loading takes so many time.

 

Yesterday i found another problem - i was reloading mission and game freezes. There is no problem if You loose mission and choose to play again...only when loading without mission defeet.

Is it windows 10? What game installation do you have, ultimate collection?

Share this post


Link to post
Share on other sites
6 hours ago, FunkyFr3sh said:

Is it windows 10? What game installation do you have, ultimate collection?

Yes, windows 10, game from Origin. It loads but "freez" on the Creating theories on enemy plans. Even Windows is not working then - but after 3-4 minutes it unfreezes and work excellent :)

Share this post


Link to post
Share on other sites

I got my tiberian sun working on windows 10 by setting the rendering options as follows

1.DxWnd

     a. Windowed Mode

     b. No window border

2. Emulation as Primary Buffer

3. Graphics Patch enabled

4. then i had to set my resolution in the sun.ini file to 1280X720 as the game kept freezing at 1080p when moving the mouse.

 

Hope this helps

I used the cncnet installer if that makes any difference

Edited by Mr. Bones

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×