Jump to content
  • 0

RA2 YR Mouse required error



I purchased RA2 YR from Origin about a week ago now. I have been in communications with them for the past week trying to figure out why I get an error stating "A mouse is required for Playing Yuri's Revenge." Yes, I have a mouse plugged into my computer, I have a Razer Taipan. I have searched high and low for a solution before creating this question. How do I fix this error so that the game sees my mouse. I have tried starting it in compatibility mode Windows XP SP2 and 3. Running Windows 10 Pro.



Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

You've probably already tried all these, but it's all I can think of:

  • make sure your mouse driver is updated - http://www.razersupport.com/gaming-mice/razer-taipan
  • try a different usb port (preferably usb 2.0 because it's a fairly old game)
  • if you've remapped any of your mouse buttons, reset it all back to default (but first make sure your button remaps have been saved)
  • Start YR in admin mode
  • Start Razor Synapse in admin mode
  • use a different mouse (buy a cheap $10 one if you have to)


  • Upvote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...