Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Tor_Heyerdal

RA Custom Map Keeps Crashing on Start

Question

Hi. I've spent the last two days making a custom map, and every time that my friend and I try to launch it, both of our clients crash immediately upon game start, and we both get the same error: "Red Alert crashed at address 0x004fef6c. Ask in the CnCNet forums for more information." So... here I am in the CnCNet forums asking for more information. lol. I have no idea what this error means, or how to decode it, and I have no idea what I might have done wrong in the map to botch it so hard. lol. I did absolutely zero trigger or AI meddling. I just started a new blank map, painted it up, reset the starting locations, and saved it. Is there something I'm missing? I've tried googling the error, and I've found absolutely nothing. I've also tried googling things like "Red Alert custom map keeps crashing", and that's also begotten no results. Everything's all for RA 2 or 3. Can someone please shed some light on the situation?

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

I found the crash in the database,

[General]
GrowthRate=0

 

GrowthRate can't be 0, you'll have to change that

Share this post


Link to post
Share on other sites
  • 0

@Tor_Heyerdal

Crash seems to be related to the GrowthRate of the ore, did you maybe change that?

 

Can you tell us the name of the map so we can search the DB for it and have a look? Or you can also upload it here in the forums directly

Share this post


Link to post
Share on other sites
  • 0

Alright. Well, you are indeed correct that I had changed the growth rate to 0. I forgot about that. I'm fairly certain that that's the only text value I altered anywhere. So I changed it back to .2, which I recall it being before I changed it. But the crash kept on happening. So I changed it to 1, and the crash is still happening. :\

Share this post


Link to post
Share on other sites
  • 0

You probably just have multiple versions of the map and loaded the old unmodified one I guess. If the address is still "004fef6c" then that's the case, if it's different then you got a different crash.

Share this post


Link to post
Share on other sites
  • 0

After initially saving it, I have never used "Save as" again, I have only used "Save Scenario", so there should only be one copy of the map. I never *made* a second copy of it. And when I'm in the game lobby choosing the map, there's only *one* copy of the map there *to* choose. So unless there's something really esoteric about CnC that I have no way of knowing until someone tells me, there's no possible way that there could be two copies of the map. And yes, the error is still giving the same address.

Share this post


Link to post
Share on other sites
  • 0

In fact, I have even closed the scenario in the map editor, and then re-opened it to make absolute certain that the updated save is actually taking, and it is. When I re-open the only map, and I check the "Text" field, the GrowthRate has, indeed, remained updated.

Share this post


Link to post
Share on other sites
  • 0

I figured it out! The growth rate kept on changing itself back to 0 for some reason. I would open the Map Editor, it would ask me if I want to start a new map, I would say no, I would find my map from the list, and it would say "Growth Rate in General changed from 2 to 0", and I would open the map, and I would open the Text field, and I would change it back to 2, and I would "Save Scenario", and then I would close the editor. Then I would re-open the editor and when I find the map in the list, it still says that the Growth Rate in General is changed from 2 to 0. I repeated this process several times, and it kept on repeating. Then I remembered my previous post where I said that I have not used "Save As" once since the first time I saved. On a random hunch, I decided "maybe that's the problem," and it would seem that I was right. When I used "Save As" instead of "Save Scenario", the change actually registered, and now the map is working. This would be that esoteric detail I was looking for. I'm glad I found it. But I never would've found it at all without your help. You were very much correct. Thank you very much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By Yon
      I can play the game everything is working but my mouse or cursor can't go to de in game menu buttons when I set up my base I want to build a power plant but I can go there with the cursor please help
      I know there is a file where I can change it but I don't know what file
    • By qymon
      It is a really shame but I have to report that in China there are many guys cheating in mutiplayer games in Mental Omega on CnCNet. This makes many players fear to join a pubilc game lobby.The situation is not good at all.Are there any ways to prevent cheating?
      I have tried one cheat tool. It has many cheat functions but most of them can not function in mutiplayer games.I think it must be the result of the hard working of the WestWood studio and you CnCNet groups to eradicate cheating.
      However,there are still a few functions that still works.The cheat tool, which seems to cheat through editing the data in computer's memory,can still do such things:
      1.Change the sight of the unit you select,then make most of the shroud removed.
        How much shroud one player has removed seems won't sync with other players so it won't cause sync error?
      2.Break the limits of building structures. That's to say, cheaters can build everywhere.
        Maybe the judgement on building structures is local and won't cause sync error?
      3.Break the limits of tech level or other things to produce a unit.
        I have no idea how it managed to do this,but the cheater can build every units registered in ini files,ignoring building limits.

      Meanwhile,players with modified ini files seem still able to start games with others and the warning "the player modified his game" seems appear for everyone,including innocent ones.We players have no idea when join in a public game lobby.
      Cheat problems are serious nowadays in Mental Omega.Are there any ways to prevent these kinds of cheating? We players need your technical help.
    • By [BR]Ak47
      hello , i have a doubt , my gold medal on red alert disappeared after i change my damaged harddisk to another , who can add my goldmedal to my account via auth ? my account is ->> Ak47 , nicks ->> [BR]Ak47 or [Ak47-BR]. awaiting for answer, thanks.
    • By Eisengeist
      I only got to play C&C Sole Survivor a little while before the servers went down and didn't get to try all its modes but it was pretty cool having every unit controlled by a player.   Plus some of the more elusive units made an appearance.   Isn't it the only game where you could play as a Viceroid, or at least the classic style Viceroid?  Hopefully it wouldn't be too big a project to build it into the remasters.
    • By hosin
      I was connecting to the TS game lobby through cncnet, and found that i entered the chatting channel of RA. The rooms shown on the left is for TS, but the chat room in the middle isfor RA. Do they share the channel or how can I fix the problem?
  • Recently Browsing   0 members

    No registered users viewing this page.

×