Jump to content
  • 0

Red alert 2 will not install



Hello, Recently I bought a new laptop for college, I have been trying to install Red Alert 2 on it, as I am a huge fan of the game. 

I have the physical disks for both the soviet and the allied campaign, 
At any rate I will run the installer ( I have tried both disks) then I get the UAC "do you want to let this program make changes to your computer" ( the publisher and source are unknown.) 

I click "yes" I hear the Hdd and the CD drive bay speed up for a few minutes then nothing, I check task manger, nothing Ra2 installer isn't running, just the usually background programs.

When I installed on Win 7 I was able to use the command "sec stop secdrv" in command prompt to install Ra2 and Yuri's Revenge.

However when I tried to do this for win 10, command prompt spat out an error "the service has not been started"!

Sooo any assistance would be awesome!!

Thank you!!

Sincerely Ben Bower

Edited by 555_Soul_555
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0
5 hours ago, RA168UK said:

Please make sure that you are running the installer as admin by right clicking on the exe file and then choosing run as administrator

This is not possible on Windows 10, as the installer simply refuses to work.


Please refer to these guides for installing:



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...