Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0
Mrvecz

Mental omega client cannot launch ?

Question

Hi

After posting on Revora Net in M.O. client launch issues, i was told to seek a user named Rampastring on these forums.

 

The problem is with the client that launches the actual mod, i never actually managed to get even to the menu of the game.

Everytime i launch it, a picture pops up with the allied unit in the skies, then it stops responding on itself (Without me doing anything) and PC terminates it and asks me if i would like to send data to Microsoft about the crash (For some reason ?)

So far i tried this

- Restart of PC

- Reinstalation of RA2 YR

- Setting the compability of both client and syringe exe to SP 3 or SP2, also giving both of them admin access, neither worked

- Game is patched to 1.001

- Game is installed as part of the First Decade

- Disabling anti virus (Avast)

 

It does generate a log though !  i put the latest one in attachments

ClientCrashLog_4_12_2017_16_12.txt

What i would need is the examination of the log, to find out the main source of the issues.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1

If you have another Windows 7 system and know how to use regedit, you can try taking a look at HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}, back up that registry hive and then restore it on the problematic system. Taking the hive from a Windows 8 or 10 system could work too.

If your Windows 7 is 64-bit, you might also need to restore HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}.

Share this post


Link to post
Share on other sites
  • 0

Your Windows 7 installation is corrupt. Particularly, you're missing the "Task Bar Communication" {56FDF344-FD6D-11D0-958A-006097C9A090} COM component.

Try opening a command prompt with administrator rights, and then run the following command

sfc /scannow

Keep an eye on it to see if it reports any corrupted files. Check if the client works afterwards.

Edited by Rampastring

Share this post


Link to post
Share on other sites
  • 0

Nothing worked, with some more research i found that the files were quarateed by overzealous adwcleaner, but i have no way of getting them back (And no, i wont reinstall the windows for just one mod)

 

The scan itself even with full admin rights didnt found anything and mod still crashes on startup

 

56FDF344-FD6D-11d0-958A-006097C9A090 is the registry thingy thats probably missing (I have 0 clue about this so bear with me:(

I saw some people just uploading these file, but all links i found are expired so i dont know what to do now

 

 

 

 

 

 

Edited by Mrvecz
Cleaning things up

Share this post


Link to post
Share on other sites
  • 0

When i try to import the missing (Well its not really missing, i managed to find it but its probably corrupted or something) registry from other W7 PC it pops a error saying that it failed importing (Register failed to import all data, some keys are already opened by the system or other processes ?)

 

Theres a odd thing, if i delete the register thingy with the task bar com file from it and try to import the "Repaired" fixture from another PC, it pops the message above. If i import the backup i made, it imports just fine.

The main thing is that the "fixtures" have different text in them, adding this text from the gut registry thingy to the corrupted registry thingy (Aka just replacing every text with the gut one) renders the file impossible to import.

 

Kinda wish Mental Omega just have a freakin exe to launch, i am not eager to play MP in it anyway 

 

 

Edited by Mrvecz

Share this post


Link to post
Share on other sites
  • 0

I solved it

Thanks you SOO MUCH for your help ! :)

It took some time but i managed to snatch these files from a passworded computer that was x64 and now its works... and is stable

Now only some resolution tweaking is in order, but thats trivial stuff.

So once again, thank you

 

 

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By KlaPPer SnaPPer
      When trying to play QM on RA2 Yuri's revenge it says I don't [which I do!!!] have a ladder account for the game and asks if I want to sign up, but when I do it just shows me I'm signed up with all my accounts listed. PLEASE HELP! I've deleted and reinstalled everything and this all works for other users on a different computer. PLEASE HELP
    • By AttackRed
      Hello, I am trying to set red alert 2 YR to play on my three computers but all of them when the game starts they dont load to game so each one start alone, I tried to open the firewall but still doesnt work, and when i try to play on lan 2 of them work but one which is origin version crash when i open the lan area. 

    • By Killerbote
      Everything else in the options tab can be changed, but whenever I try changing the renderer in YR, it says
      “Save settings failed! Error message: access to path (directory) ||\ddraw.dll is denied”
      everything else works fine, and I’ve given it admin permissions and moved outside of Programs 86 folder
      anyone seen or know how to fix this? I’ve googled around and could only find one similar problem from 2016; which ended up fixing itself after the OP played around with settings.
      I am on windows 10 
    • By mahmoudcj
      the Game was work but was so lag and slow move , so i download CNCNet5 and installed it again and i found this message  
      yuri revange was crashed ,error message
      method not found: void perview extractor,MapThumbnailExtractorctor(rampstring.tools.IniFile,Int32)
      please help how to fix and how get play the game without lag and slow move
    • By Peanut
      I can not fix this problem. Please help

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...