Jump to content

CnCNet Forums

Search In
  • More options...
Find results that contain...
Find results in...
  • 0

Mental omega client cannot launch ?


Mrvecz
 Share

Question

Hi

After posting on Revora Net in M.O. client launch issues, i was told to seek a user named Rampastring on these forums.

 

The problem is with the client that launches the actual mod, i never actually managed to get even to the menu of the game.

Everytime i launch it, a picture pops up with the allied unit in the skies, then it stops responding on itself (Without me doing anything) and PC terminates it and asks me if i would like to send data to Microsoft about the crash (For some reason ?)

So far i tried this

- Restart of PC

- Reinstalation of RA2 YR

- Setting the compability of both client and syringe exe to SP 3 or SP2, also giving both of them admin access, neither worked

- Game is patched to 1.001

- Game is installed as part of the First Decade

- Disabling anti virus (Avast)

 

It does generate a log though !  i put the latest one in attachments

ClientCrashLog_4_12_2017_16_12.txt

What i would need is the examination of the log, to find out the main source of the issues.

Link to comment
Share on other sites

6 answers to this question

Recommended Posts

  • 1

If you have another Windows 7 system and know how to use regedit, you can try taking a look at HKEY_LOCAL_MACHINE\SOFTWARE\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}, back up that registry hive and then restore it on the problematic system. Taking the hive from a Windows 8 or 10 system could work too.

If your Windows 7 is 64-bit, you might also need to restore HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Classes\CLSID\{56FDF344-FD6D-11D0-958A-006097C9A090}.

Link to comment
Share on other sites

  • 0

Your Windows 7 installation is corrupt. Particularly, you're missing the "Task Bar Communication" {56FDF344-FD6D-11D0-958A-006097C9A090} COM component.

Try opening a command prompt with administrator rights, and then run the following command

sfc /scannow

Keep an eye on it to see if it reports any corrupted files. Check if the client works afterwards.

Edited by Rampastring
Link to comment
Share on other sites

  • 0

Nothing worked, with some more research i found that the files were quarateed by overzealous adwcleaner, but i have no way of getting them back (And no, i wont reinstall the windows for just one mod)

 

The scan itself even with full admin rights didnt found anything and mod still crashes on startup

 

56FDF344-FD6D-11d0-958A-006097C9A090 is the registry thingy thats probably missing (I have 0 clue about this so bear with me:(

I saw some people just uploading these file, but all links i found are expired so i dont know what to do now

 

 

 

 

 

 

Edited by Mrvecz
Cleaning things up
Link to comment
Share on other sites

  • 0

When i try to import the missing (Well its not really missing, i managed to find it but its probably corrupted or something) registry from other W7 PC it pops a error saying that it failed importing (Register failed to import all data, some keys are already opened by the system or other processes ?)

 

Theres a odd thing, if i delete the register thingy with the task bar com file from it and try to import the "Repaired" fixture from another PC, it pops the message above. If i import the backup i made, it imports just fine.

The main thing is that the "fixtures" have different text in them, adding this text from the gut registry thingy to the corrupted registry thingy (Aka just replacing every text with the gut one) renders the file impossible to import.

 

Kinda wish Mental Omega just have a freakin exe to launch, i am not eager to play MP in it anyway 

 

 

Edited by Mrvecz
Link to comment
Share on other sites

  • 0

I solved it

Thanks you SOO MUCH for your help ! :)

It took some time but i managed to snatch these files from a passworded computer that was x64 and now its works... and is stable

Now only some resolution tweaking is in order, but thats trivial stuff.

So once again, thank you

 

 

 

  • Upvote 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • By XMaDTanKX aka T-90
      Hello
      I'm doing some video stuff with Yuri's Revenge and every time I try to open the XCC Sound Editor that comes inside the XCC Mixer, the program just closes itself and won't let me do anything. I only need to extract some audios from langmd.mix\audiomd.mix\audio.bag as wave files to put them into a video.
      I'm using XCC Utilities 1.47 and surprisingly with older versions like 1.12 or 1.40 the issue won't happen, but I can't read Yuris Revenge, only Red Alert 2.
      Any idea of what could be causing this and any solution?
      Thanks in advance.
    • By Insurgent
      Hello, i've just played minutes ago, but after restarting my pc this came out when i tried to open cncnet-yuri's revenge.
      Can anyone give me some hints so I can solve this problem?
      Kind regards.

    • By XMaDTanKX aka T-90
      I've been playing a few games online and I've noticed that the Scroll Speed is way too fast even when it's set at 0, and when I say too fast I mean near to be uncontrollable.
      I don't have this issue playing the vanilla games Ra2 / YR and/or the CNC Net client on Skirmish mode, I usually set it as fast, but in online games I'm forced to set it to slowest / 0 and still is too fast.
      Anyone knows what could be causing this problem and any possible solution?
      Any help is apreciated.
    • By CnCRedAlertFan
      Can't host a game of Yuri's Revenge in CnC Net, only i load and I get a Victorious screen.
       
       

    • By CnCRedAlertFan
      First time I was able to load into the game but the update failed, I got an error in the update and said something about firewall not allowing clientdx.exe to update. My firewall and anti-virus arent the issue and i read others are also having this problem.
      Now I can't even launch the game due to a crash
       
      Update: fixed by reinstalling
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...