Jump to content

Dawn of Tomorrow issues with cncdraw


Recommended Posts

I've tried to update to the 2018 version of cncdraw as I am finishing off my mod to release sometime this decade :) The short version is that I am getting crashes when I try to play the campaign :(

I've done testing with 2 different versions of CNC-draw. The first is dated Dec 2012 and the second is Nov 2018.

With the 2012 version, everything works fine, with the exception that the aspect ratio is wrong on my 1080p display, all stretched out of shape. With the 2018 version, the aspect ratio is better, but the menus flicker really badly, like they are being rendered really slowly over time. Also my campaigns crash with the following error message.

The instruction 0046583b referenced memory at 0d6503e4 (the address changes)
The memory could not be read from

My CoA campaign crashes consistently when starting mission 6, after the intermission screens. My FoT campaign crashes consistently on mission 7, but only after having finished the campaign and started it again.

Any ideas?

Link to comment
Share on other sites

  • 2 weeks later...

Sorry for the delay on replying Funky, I was wanting to give it a proper test rather than rushing it.

So the first thing I can note is that the menu flicker does seem to be fixed now.

The second thing is that I think because I updated my drivers, the full screen view I was getting before (scaled to fit, with smooth scaling) is no longer happening, now I get bad pixellation. I'd like to offer a window box and a smooth scaling option in my installer, do you know what happened there?

On a more serious note, I'm still getting crashes. One of them is inconsistent.

posted image

I get this error when I begin FoT mission 7, but only after I beat it once and then go through the campaign again.


With the CoA campaign, things are more complex. I had three goes through it, the first time, I got this error when finishing CoA3 (between the victory vid and the start of the world map):

posted image

I did not get this error on the second and third runs of the program for this test. For the second run, I was able to go through the campaign twice with no crashes. For the third run, I got this when beginning mission 6:

posted image


Hope this helps. Let me know if there's anything more I can try

Link to comment
Share on other sites

You can set your display mode to stretched, renderer to opengl and then click on advanced setting. In there you'll find the filters, nearest = sharp, cubic = smooth.


One crash happens while scaling 2x, that code is used for the cutscenes but also the mission selection screen and all other places where files with size of 320x200 (or below) are used.

The other one seems to be related to a .shp file, can't really tell what exactly it is but it could be related to a file of a given theater or while displaying a dialog.


Are you sure these crashes only happen with 1 of the two cnc-ddraw's you tried?

Link to comment
Share on other sites

When I did my first round of testing, I gave both the 2018 and the 2012 versions extensive goes. The 2012 one worked fine, just the aspect ratio was all wrong.

I'll give the filters a try and see how they look to see if it looks like it did before, thanks.

Is there anything more I can do to get better logging or stack traces?

Link to comment
Share on other sites

  • 5 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...