Jump to content
  • 0

Running RA2/YR properly without CnCNet



CnCNet works perfectly with the Origin version of the game - no black-screen or psychedelic colors, no freezing thirty minutes into the game, can even get it to run in windowed mode through the client without Windows throwing a hissy-fit about color modes.

Only problem is, it only lets me play skirmish or multiplayer modes. Sure, I've spent a lot more time with those, but once in a while I'd like to play the campaign; I don't recall ever personally completing more than one mission .

Now, I've already got that ddraw.dll fix going, and for Red Alert 2 it runs damn-near perfectly as well, I just replayed a pair of Soviet missions with it. But so much as having ddraw.dll in the game's folder makes Yuri's Revenge crash on startup with a "Main executable for Yuri's Revenge has stopped working" popup (although I suppose that's a step up from YR just refusing to acknowledge them, or causing the same issues for different reasons no matter what I change). Worse thing is, if I don't have it there, I universally get just a black screen when I try to run the game on its own. I've even tried copying ts-ddraw.dll out of CnCNet's Resources folder and into the main folder, and the game seemed perfectly content to ignore it.

The gist of it is, how do I run the game with CnCNet's improvements without using CnCNet's launcher? Is there something else I need to do to get the game to acknowledge ts-ddraw, or do I need to do something else entirely?

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0
10 hours ago, Lud0wig said:

Just rename ts_ddraw.dll to ddraw.dll lol

Still just crashed on startup, unfortunately.

10 hours ago, FunkyFr3sh said:

This worked almost perfectly, however, thanks. Only issue was a crash when I tried to close Yuri's Revenge after playing a campaign mission, a popup saying a ddraw.dll error code 00000006. Still, a crash when I'm trying to quit anyway is far better than what I'd been getting.

EDIT: Didn't get the same crash when testing RA2 base game, though, so there's that.

Edited by Kadorhal
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...