Jump to content
  • 0
vincevance07

C&C Gold does not start

Question

Every time I try to run the C&C95.exe, (for single player campaign) I get an error message that says, "instruction at 1e998aae referenced memory at 1e998aae. The memory could not be read from".

Then my computer waits for a bit before giving me the "C&C95.exe has stopped working" message. Has anyone else come across this error before?

Any help is appreciated!

Share this post


Link to post
Share on other sites

22 answers to this question

Recommended Posts

  • 0

it's crashing somewhere, but not in the game itself.

Are you using our download or unpatched first decade/ultimate collection?

 

Try to disable cnc-ddraw in the options and see if it works then. Also update your graphic drivers

Share this post


Link to post
Share on other sites
  • 1
18 minutes ago, Burning_wreck said:

I have the same issue, mouse pointer jumping from edge to edge. I can slowly move my pointer a few centimeters from the ege before it jumps so I don't think its the speed.  I can use the mouse sort of normaly if I hold the right mouse button, ofcourse playing like that is not realy an option.

Also when playing the first mission of the GDI I get 2 screens, a small one in the right lower corner, that freezes after a sec, and the rest that I can sort of play on with RMB pressed.

If you found a fix I would very mutch like to know it.

 

 

 

 

I recently found out whats the problem with that, the following steps should help you to sort it out:

 

1) Open  CCConfig.exe and make sure "Use CnC-DDraw" and "Limit frame rate" are checked.

2) Rename your c&c95.exe to c&c95_123.exe and make a new shortcut for it on your desktop

3) Right click c&c95_123.exe, Properties->Compatibility, make sure "disable display scaling on High DPI settings" is checked and all other settings are disabled (Don't enable any other compat mode!)

 

Hopefully Nyerguds can update his installer soon so we don't run into these problems anymore

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)
33 minutes ago, FunkyFr3sh said:

it's crashing somewhere, but not in the game itself.

Are you using our download or unpatched first decade/ultimate collection?

 

Try to disable cnc-ddraw in the options and see if it works then. Also update your graphic drivers

I am using the download from the link off of this website, the filename is "cc95v106c_r3_u4_full.exe". I'm pretty sure it is the patched version. I'll try disabling cnc-ddraw and get back to you. Thank you

UPDATE: That seems to have worked, I turned No-CD mode back on when it asked me to insert a disc in my drive, but at least the game loads now.

Thanks for the help!

Edited by vincevance07
update with current information

Share this post


Link to post
Share on other sites
  • 0

The configuration tool itself tweaks some compatibility settings when saving, so I suspect that that is exactly what fixed it, and not any tweaks you made inside the tool. You probably just needed to run it once and save.

By the way, if you do play without CD, there are video download packs available to still get the full game experience.

Share this post


Link to post
Share on other sites
  • 0

I have the same problem and need help.

Trying to run C&C Gold - not First Decade with patch but the full game installer provided by CNCNet for no avail.
The only thing I tinkered is the cnc-ddraw option:

- If I run the game with this option enabled, I receive the same (and annoying) memory error message from the first post of this discussion (vincevance07). Then I have to wait about 2 f***king minutes to regain control of my computer, for the game oddly freezes my entire PC, until a window with an error in the main executable of the game appears and the rest of the game crash for good, as always.

- If I try to disable it (cnc-ddraw), I get a black screen and every single key I hit it returns to the desktop, but the EXE is still running.

My sistem specs: Intel i7 3740, 16GB RAM, GeForce GTX1070, Sound Blaster Z, Windows 10 Insider x54.

Need help with this issue: anyone knows what else I can do to? Thanks in advance.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Kyle2k10 said:

I have the same problem and need help.

Trying to run C&C Gold - not First Decade with patch but the full game installer provided by CNCNet for no avail.
The only thing I tinkered is the cnc-ddraw option:

- If I run the game with this option enabled, I receive the same (and annoying) memory error message from the first post of this discussion (vincevance07). Then I have to wait about 2 f***king minutes to regain control of my computer, for the game oddly freezes my entire PC, until a window with an error in the main executable of the game appears and the rest of the game crash for good, as always.

- If I try to disable it (cnc-ddraw), I get a black screen and every single key I hit it returns to the desktop, but the EXE is still running.

My sistem specs: Intel i7 3740, 16GB RAM, GeForce GTX1070, Sound Blaster Z, Windows 10 Insider x54.

Need help with this issue: anyone knows what else I can do to? Thanks in advance.

Try to enable cnc-ddraw again in the config program, now go into your game folder and look for ddraw.ini, open it in notepad and switch the renderer (If it's "opengl", try "gdi")

Share this post


Link to post
Share on other sites
  • 0

Thanks, FunkyFr3sh, but ddraw.ini was already set to gdi.

Tried opengl instead, again for no avail. At least, this crash with opengl did not freeze my entire PC.

Thanks for the tip, anyway.

Share this post


Link to post
Share on other sites
  • 0

OK, I got C&C95 to (at least) to load the main screen messing with the C&C Config tool (windowsd mode) + compatibility mode (Windows XP + 256 colors + admin).

The problem now is:

1 - Mouse is simply uncontrollable: in addition to be moving at the speed of light, it appears only  on the edge of the game screen, 'jumping' from one edge to another, and I'm unable to point the cursor to the centre of the game screen - where the main buttons (and the game) is. Using the "Automatically adjust mouse sensivity to resolution" in the Config Tool does not make any difference. Like I said, because of this issue, I'm unable to try any solution ingame (like change mouse sensivity from the game options menu.

2 - Fix the screen issue, 'cause I want - if possible - to run the game in full screen.

It's very hard for me to accept that I'm the only one having this issues and I think this CNCNet games need more work to make it full compatible with modern systems like Windows 10. It's crystal clear that they are not.

Thanks in advance.

 

Share this post


Link to post
Share on other sites
  • 0

I tried the cncnet>downloads> installation and cnc95.exe (from the folder)  seems to load, but the "New game" button is broken.

 

Edited by Myg

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, Myg said:

I tried the cncnet>downloads> installation and cnc95.exe (from the folder)  seems to load, but the "New game" button is broken.

 

What is broken - and the devs seems don't give a sh*t about it - is the mouse issue that not allow me to play the game.

Share this post


Link to post
Share on other sites
  • 0

I did not get that issue. Your issue might be a really rare situation that can't be easily reproduced.

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Myg said:

I tried the cncnet>downloads> installation and cnc95.exe (from the folder)  seems to load, but the "New game" button is broken.

 

You can't play the campagin with "TiberianDawn_Online_installer.exe", nor "cnc95.exe" - Those are for multiplayer only.

 

4 hours ago, Kyle2k10 said:

OK, I got C&C95 to (at least) to load the main screen messing with the C&C Config tool (windowsd mode) + compatibility mode (Windows XP + 256 colors + admin).

The problem now is:

1 - Mouse is simply uncontrollable: in addition to be moving at the speed of light, it appears only  on the edge of the game screen, 'jumping' from one edge to another, and I'm unable to point the cursor to the centre of the game screen - where the main buttons (and the game) is. Using the "Automatically adjust mouse sensivity to resolution" in the Config Tool does not make any difference. Like I said, because of this issue, I'm unable to try any solution ingame (like change mouse sensivity from the game options menu.

2 - Fix the screen issue, 'cause I want - if possible - to run the game in full screen.

It's very hard for me to accept that I'm the only one having this issues and I think this CNCNet games need more work to make it full compatible with modern systems like Windows 10. It's crystal clear that they are not.

Thanks in advance.

 

Can you try if the multiplayer version works for you without issues? https://downloads.cncnet.org/TiberianDawn_Online_installer.exe

The multiplayer version (TiberianDawn_Online_installer.exe) was made by me, if it works then I'll tell nyerguds the settings I used so he can apply it to his patch for the full game (cc95v106c_r3_u4_full.exe)

Share this post


Link to post
Share on other sites
  • 0
33 minutes ago, Myg said:

I did not get that issue. Your issue might be a really rare situation that can't be easily reproduced.

I don't think so, Myg. My mouse is an ordinary one, my system runs Dune2000 and Red Alert (the first one) without an issue.

I have the same problem on my PC AND my Asus laptop, with different hardware specs. Both runs Windows 10 x64, Insider builds. For me, it is clear that this game is not fully compatible yet.

The other game I cannot run is Tiberium Sun, because it freezes a few seconds after when I start to play. This problem in TS is well reported by other users.

Share this post


Link to post
Share on other sites
  • 0
7 minutes ago, Kyle2k10 said:

I don't think so, Myg. My mouse is an ordinary one, my system runs Dune2000 and Red Alert (the first one) without an issue.

I have the same problem on my PC AND my Asus laptop, with different hardware specs. Both runs Windows 10 x64, Insider builds. For me, it is clear that this game is not fully compatible yet.

The other game I cannot run is Tiberium Sun, because it freezes a few seconds after when I start to play. This problem in TS is well reported by other users.

For your Tiberian Sun issues, try to apply my patch: https://forums.cncnet.org/topic/2606-tiberian-sun-patches-fix-for-the-windows-8-10-menu-problems-and-more/

 

You need to specify what files you used to install/patch the games, otherwise it will be difficult to help since we got multiple people working on the games.

 

RedAlert1_Online_Installer.exe -> I made this one

TiberianDawn_Online_installer.exe -> I made this one

TiberianSun_Online_Installer.exe -> I made this one

RA1installer.exe -> I made this one

TSpatch.exe -> I made this one

cc95v106c_r3_u4_full.exe -> Nyerguds made this one

TSinstaller3-beta11r6.exe -> Tore made this one

 

 

Share this post


Link to post
Share on other sites
  • 0

Just tested Nyerguds full installer from his website. This issue is confirmed. The CnCNet version doesnt suffer from the same issue.

Using the latest Windows 10 x64.

Edited by Myg

Share this post


Link to post
Share on other sites
  • 0
9 minutes ago, Myg said:

Just tested Nyerguds full installer from his website. This issue is confirmed. The CnCNet version doesnt suffer from the same issue.

Using the latest Windows 10 x64.

I don't understand what you're saying, Myg.

The link to download C&C TD Single Player, Windows Version was provided by CNCNET: it points to Command & Conquer Gold: Project 1.06:

http://nyerguds.arsaneus-design.com/cnc95upd/cc95p106/

The file is cc95v106c_r3_u4_full.exe.

If is another C&C from CNCNET, please point me to the right direction.

 

Share this post


Link to post
Share on other sites
  • 0
36 minutes ago, FunkyFr3sh said:

For your Tiberian Sun issues, try to apply my patch: https://forums.cncnet.org/topic/2606-tiberian-sun-patches-fix-for-the-windows-8-10-menu-problems-and-more/

 

You need to specify what files you used to install/patch the games, otherwise it will be difficult to help since we got multiple people working on the games.

 

RedAlert1_Online_Installer.exe -> I made this one

TiberianDawn_Online_installer.exe -> I made this one

TiberianSun_Online_Installer.exe -> I made this one

RA1installer.exe -> I made this one

TSpatch.exe -> I made this one

cc95v106c_r3_u4_full.exe -> Nyerguds made this one

TSinstaller3-beta11r6.exe -> Tore made this one

 

 

Thanks, man but - as I already asked Myg - I need to know where can I download this  TiberianDawn_Online_installer.exe of yours, because CNCNET points me to download the Nyerguds version in the Command & Conquer Gold: Project 1.06 site.

Thanks to both of you for the help

Edited by Kyle2k10

Share this post


Link to post
Share on other sites
  • 0

TiberianDawn_Online_installer.exe is just a plain multiplayer only version, that's why Myg was referring to it as the "CnCNet version" since it was made specially for CnCNet Online games. 

cc95v106c_r3_u4_full.exe is the right file (the only one you can find for  Single player), we'll have to wait for Nyerguds to help out with this one.

 

My guess is that Nyerguds enabled some compatibility modes for the game executable which are causing all the issues.

If you want to try already now without waiting for him, do the following:

1) Enable cnc-ddraw in the config program

2) Open ddraw.ini in your game folder and make sure the renderer is set to "gdi".

3) Disable all compatibility modes C&C95.exe, make sure you apply them for all users too.

After that, don't open the cnc config program again, it might revert some changes and break it again.

Share this post


Link to post
Share on other sites
  • 0

ddraw.ini

Also, If windowed is enabled, then make sure mhack is enabled too.

Set maxfps to 60 to prevent fast scrolling issues

Share this post


Link to post
Share on other sites
  • 0
On ‎17‎-‎11‎-‎2017 at 7:08 PM, Kyle2k10 said:

OK, I got C&C95 to (at least) to load the main screen messing with the C&C Config tool (windowsd mode) + compatibility mode (Windows XP + 256 colors + admin).

The problem now is:

1 - Mouse is simply uncontrollable: in addition to be moving at the speed of light, it appears only  on the edge of the game screen, 'jumping' from one edge to another, and I'm unable to point the cursor to the centre of the game screen - where the main buttons (and the game) is. Using the "Automatically adjust mouse sensivity to resolution" in the Config Tool does not make any difference. Like I said, because of this issue, I'm unable to try any solution ingame (like change mouse sensivity from the game options menu.

2 - Fix the screen issue, 'cause I want - if possible - to run the game in full screen.

It's very hard for me to accept that I'm the only one having this issues and I think this CNCNet games need more work to make it full compatible with modern systems like Windows 10. It's crystal clear that they are not.

Thanks in advance.

 

I have the same issue, mouse pointer jumping from edge to edge. I can slowly move my pointer a few centimeters from the ege before it jumps so I don't think its the speed.  I can use the mouse sort of normaly if I hold the right mouse button, ofcourse playing like that is not realy an option.

Also when playing the first mission of the GDI I get 2 screens, a small one in the right lower corner, that freezes after a sec, and the rest that I can sort of play on with RMB pressed.

If you found a fix I would very mutch like to know it.

 

 

 

Share this post


Link to post
Share on other sites
  • 0
23 hours ago, FunkyFr3sh said:

"disable display scaling on High DPI settings"

This seemed to have done the trick, I can use the mouse normaly now :)

As for the 2 display windows, I think I've read somwhere thats because the map was smaller than my screen, on other  maps I don't have that problem.

 Thank you very mutch for your help :)  now I can play this game on my pc with the mouse, I have the first 2 C&C's on my playstation, and RTS with a controler sucks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×